When I use Finder on OSX 10.11.6, selecting any of the "Arrange by date [modified/last opened/created/added]" splits up the window into various vertical subcategories which I can either horizontally scroll through or go through one by one and select "show all" to have them treated like regular files.

Is there anyway to disable this and just have all the files in the folder sorted chronologically in the same way it treats files when you sort by name? I believe the behavior I'm looking for is the same as Windows 10 behavior.


Just to clarify, I am wanting to achieve this in icon view, not in one of the other views.

  • I'm pretty sure it only does that in the 'All My Files' folder, which is a special folder type.
    – Tetsujin
    Commented Jun 22, 2017 at 15:49
  • 1
    @Tetsujin sadly no, i just checked and it does it in Downloads Desktop and a bunch of folders that I made on my own
    – mc-lunar
    Commented Jun 22, 2017 at 15:58
  • hmm... yup, it does it in anything first set to icon view before choosing that sort. As I never use icon view, I hadn't realised. I mainly use list view & then you can sort by clicking any header & that doesn't happen.
    – Tetsujin
    Commented Jun 22, 2017 at 16:07
  • @Tetsujin unfortunately in list view it does the same thing, even afte clicking a header to sort. i.imgur.com/13CzNYL.png
    – mc-lunar
    Commented Jun 22, 2017 at 16:24
  • Yes, but the trick in list view is to remove the View/sort [set to None] & just click the headers instead
    – Tetsujin
    Commented Jun 22, 2017 at 16:28

1 Answer 1


Right Click → Show View Options. In the small window that opens, set Arrange By and Sort By to "None". Close the small window.

Right Click Again → Clean Up ByDate Modified or Date Created.

Unfortunately, there is no equivalent option for "Last Opened" or "Added", as far as I'm aware.

  • damn this sure isn't intuitive but thanks so much !
    – mc-lunar
    Commented Jun 23, 2017 at 20:19
  • Great question. But not seeing any Show View Options when I right click. However, I notice when I right click in empty space I can uncheck Use Grouping, which then produces a giant mess. But then I can right click again and choose Sort by and then Date Added, etc. :-)
    – sh37211
    Commented Apr 1, 2023 at 18:07

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .