1

I am moving data from a Drobo 5D to a NAS (FreeNAS). I am using this command:

sudo rsync -a --stats --progress "/Volumes/Drobo 5D" "/Volumes/Archive"

Obviously, before I run the command, I mounted the Archive volume using Finder (browsed the network, found the server, clicked on the share). However, for some reason, rsync is creating a folder under /Volumes called Archive instead of using the mounted Archive volume. This is filling my system drive, instead of copying the data to the correct destination.

Here you can see the two Archive volumes:

enter image description here

Here's the output of the mount command:

/dev/disk0s2 on / (hfs, local, with quotas, journaled)
devfs on /dev (devfs, local, nobrowse) 
/dev/disk1s2 on /Volumes/Macintosh SSD 2 (hfs, local, journaled) 
map -hosts on /net (autofs, nosuid, automounted, nobrowse) 
map auto_home on /home (autofs, automounted, nobrowse) 
map -fstab on /Network/Servers (autofs, automounted, nobrowse) 
/dev/disk4s2 on /Volumes/Drobo 5D (hfs, local, journaled) 
/dev/disk5s2 on /Volumes/Macintosh iSCSI (hfs, local, journaled) 
/dev/disk3s2 on /Volumes/Backup (hfs, local, journaled) 
/dev/disk2s2 on /Volumes/Time Machine (hfs, local, journaled) 
//Matthew@Megatron._smb._tcp.local/Archive on /Volumes/Archive-1 (smbfs, nodev, nosuid, mounted by Admin)

Here's the output of the ls -l /Volumes command:

drwxr-xr-x+  3 root  wheel    102 Jun 21 22:16 Archive
drwx------   1 Admin  staff  16384 Jun 22 08:07 Archive-1 
drwxrwxr-x  16 Admin  staff    612 Jun  2 09:43 Backup 
drwxrwx---+ 43 root   admin   1530 Jun 22 08:00 Drobo 5D
lrwxr-xr-x   1 root   wheel      1 Jun 22 08:00 Macintosh SSD -> /
drwxrwxr-x  17 Admin  staff    646 Jun 22 08:00 Macintosh SSD 2
drwxrwxr-x  10 root   admin    408 Jun 14 08:19 Macintosh iSCSI
drwxrwxr-x  14 Admin  staff    544 Jun  2 09:43 Time Machine

Since posting this question, I have wondered if putting the destination path in quotes makes any difference. Commonsense tells me no, but best not to assume such things.

My questions are:

  1. Why isn't rsync using the already mounted Archive volume?
  2. How do I correctly remove the Archive folder from the Volumes folder?
  • It would be useful if you would add to your post the command mount and the output. – fd0 Jun 22 '17 at 14:17
  • 1
    Not necessarily, mount with no options or arguments, just lists the file systems that are mounted. The picture suggests that you may have ghost volumes mounted. – fd0 Jun 22 '17 at 15:11
  • 1
    We want to see the mount information as it gives more information (or at least the same info in one place) than the GUI – Mark Jun 22 '17 at 15:28
  • 1
    If you unmount the real Archive volume, delete the erroneous /Volumes/Archive folder and then remount the real Archive volume, then run your rsync command, does it work properly?. If not, repeat and use a / at the end of the source and destination volume pathnames. If that fails, add the output of the mount command from Terminal to the OP. – user3439894 Jun 22 '17 at 15:43
  • 1
    Please let us help in helping you. Open Terminal, run mount and copy/paste the result into the question (as text). Do the same for ls -l /Volumes. – nohillside Jun 22 '17 at 15:55

You must log in to answer this question.

Browse other questions tagged .