1

Context

Last night I've updated from Windows 10 Home (Installed via Bootcamp 6) to Win10 Pro.

This morning I came back to work to find out that my sound was not working. I've had a red cross on my volume icon in the taskbar.

The Device manager did not show 'Sound, video and gamecontrollers'. However there was a unknown device which just couldn't get its' drivers installed.

I've removed that hardware in order to scan again and maybe have a bit more luck. I was wrong.

That 'unknown' device has not come back yet. I've tried installing the Cirrus Logic drivers (tried literally all versions) with no luck.

I've changed to the OSX and tried updates from there. Eventually there was a software update of some sorts for OSX (El Capitano). After updating this; I did get a driver of sorts installed somehow.

The red cross has gone. I can see which devices are plugged in. However, I'm not getting any sound. Even if I plug in my headphones and set them as default .. no result. It does show that there's sound playing (Using the Test function for example) but I'm not getting anything..

I've tried uninstalling Cirrus logic drivers (for some reason you can do that from programs and features) but there's one that just won't uninstall.

I'm completely out of answers and my final solutions would be to reinstall Windows 10 Home and hope that it'll work.

Has anyone had this before; or could give me any posibilities I haven't thought of..?

Thanks !


Update #1

For those who're wondering what I've done to fix it: Reinstalled Windows (from within OSX). Yes, I did have to format everything. However I did install Windows 10 Pro and it did work perfectly.

You must log in to answer this question.

Browse other questions tagged .