2

I have a PowerMac G4 (AGP) with a working copy of Mac OS 9.2, and a corrupted copy of OS X 10.3. I would like to either reinstall Panther, or upgrade to Tiger. The catch is that for several reasons I am unable to use the CD drive to perform this installation, and am thusly relegated to using USB (I have no FireWire drives or other PPC Macs with which to perform a Target Mode install.). So my question is: how would one make a bootable Mac OS X 10.3/10.4 USB install disk(s) using self-made rips of the CDs?

In the past I have successfully installed Mac OS 9.2 via USB on this machine, however 10.3 always begins the boot process, only to hang on the "Still waiting for root" screen (White background, grey prohibitive logo), and 10.4 always gets as far as the Apple boot logo, only to hang there and stop accessing the USB drive all together.

Any help is appreciated, but please skip the generic "Are you sure it's a genuine CD?" and "Try resetting the PRAM/NVRAM/SMC". Yes I am sure they're genuine, and I have already tried that. I am almost certain the problem is with the way I am making the installer (ripping ISO via Disk Utility, and burning to USB via dcfldd or dd).

UPDATE: 01/04/2019 To those reading this out of curiosity or to perform the process yourselves, I found that my Tiger CD was corrupted, thus was the image as well, which explains why it was unable to read part way through the boot process. As for the Panther CD I never did figure out why it wouldn't boot, however I did discover the reason the Panther USB hung at the "Still waiting for root" screen is because the USB drive had insufficient power to act as a boot drive when plugged into the Mac's USB ports. I ended up buying a Leopard CD, making a USB installer out of it, and using an externally powered USB hub to circumvent this lacking power draw. I am happy to say the G4 is now chugging along on a copy of 10.5.8, albeit a bit slowly and with animations disabled.

  • Not going to ask any of the generic questions :) But it may be useful for context to understand why you are unable to use the CD drive to perform this installation? Also, booting from USB is problematic on this model, so I have the following questions: (1) What USB drives have you tried (include brand/model)? (2) How have you formatted the USB drives? (3) Do you have access to both Panther and Tiger installation discs? (4) Does the Startup Disc Manager itself work (i.e. holding option down during startup)?(5) What Boot ROM version is installed? – Monomeeth Jun 21 '17 at 22:15
  • @Monomeeth I can't use the Panther install discs because they refuse to boot (even though I can read/rip them fine once in-OS), and my copy of Tiger is a DVD (the Mac has a CD-R drive, so I can't even read it, I had to rip the image using my iMac). (1) I have tried a 4GB Dane-Elec USB 2.0 disk, which I used to install Linux on my G3 no problem. (2) The disk was formatted with Apple Partition Map and JHFS+/HFS+. (3) I do indeed. (4) Yes, it works fine, and boots other systems via USB no-prob, as does the boot command in Open Firmware. (5) Version 4.2.8f1 – Alison E.E. Jun 22 '17 at 4:17
  • The Power Mac G4 (AGP Graphics) was discontinued in July of 2000, so this system is at least 18.5 years old and time to send it to the recycling center. – user3439894 Jan 5 at 0:24
  • 1
    @user3439894 Actually, this particular tower is one of the original run models, so it's near 21 years old. And I have no intention of doing that. Some people have an appreciation for pieces of retro hardware and choose to preserve them as the technological history they are, rather than carelessly scrapping them. Would you also throw out a Super Nintendo? A perfectly functional cassette deck? A Macintosh IIcx running Apple's near completely forgotten AU/X operating system? A vinyl copy of Queen's "Jazz"? I don't use the thing as my main machine, but I'll not be so silly as to just toss it. – Alison E.E. Jan 5 at 0:39

You must log in to answer this question.

Browse other questions tagged .