3

A few days ago I moved system to an external drive and I use it with my iMac. Everything runs nice and smooth. Today my new MacBook Pro arrived, but when I switch the Macs and start my system from my external disk everytime I start I get asked for my Apple ID and password (because of the App Scenario and maybe others.)

Why can't Apple store the information that I am using two Macs with this App instead of have to type in my password every time.

Has anybody an idea?

Login screen like that: enter image description here

  • Why would you install macOS on an external drive? There are enough cloud services to sync all your data between your 2 Macs. If that's what you trying to achieve... And directly after you boot it is asking for you Apple ID and password? – LH16 Jun 21 '17 at 11:11
  • I am web developer and do not want to have two systems that needs to be synced. Just want to boot from my drive wherever I am and work. The job is not done with syncing some photos and music. Git repositories, configurations in programs and so on... So an external system disk is the easiest way. Yes – I got asked after startup. Like "log into your apple account to use this app on this Mac"... Also edited my question with screenshot. – Kevin Lieser Jun 21 '17 at 11:18
  • Would using a virtual machine on the external drive work? – Solar Mike Jun 21 '17 at 11:46
  • That needs to re setup everything. At the moment I would accept that I have to type in my apple id password – thats easier :-) – Kevin Lieser Jun 21 '17 at 11:49
  • A setup like this is no good (or better: best) practice. Somehow it's a "mobile account" approach turned up-side-down. Please add your typical workflow (home/in-house/on-site (customer)). Xy-problem alert! – klanomath Jun 21 '17 at 12:06
1

It's because authorizations are OS or profile based, but machine bound. Every time you start the OS on a Mac that is different from the last time it started up, all authorizations become invalid and have to be reissued and are stored on your disk again for the machine that you currently use.

Look in to Mobile Homes to see if that would work.

By the way, what you are doing is probably totally unsupported, so bugs are to be expected, even if it works.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .