2

I am connecting to a Linux computer through the serial port using screen on my Mac.

I ran minicom on my Linux computer and minicom uses CTRL-A for commands.

But if I enter CTRL-A, the macOS catches this and tries to interpret the command. Is there a way to temporarily disable the macOS from interpreting the CTRL-A?

1

CTRL-A is used by screen to initiate a command sequence. You can either press CTRL-Aa to send CTRL-A to the other computer or redefine it with the -e option (see man screen for details).

  • I did not have time earlier to try your suggestion. Just testing this today. CTRL-A a does not work for me. It did not pass to minicom. And for the screen -e command, looks like I have to do this for each command, is this correct? Or can I change all CTRL-A commands to say CTRL-B commands? – aobs Jun 26 '17 at 8:38
  • You can change the prefix with the -e option, see the man page for details – nohillside Jun 26 '17 at 10:50

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .