Today after opening the lid I found out that TouchPad and Keyboard doesn't work. I tried with an external USB mouse, but no success. However, keys work during the startup when I'm trying PRAM reset. Booted in safe mode but again they froze at login screen. Recovery mode didn't work either. I just can't login into my mac. My machine is MacBookPro 15" Mid 2009, running macOS Sierra.

Update: Recovery mode doesn't work, it shows nothing, but I booted with Option key to select startup disk and both keyboard and touchpad work while choosing the startup disk. But once I got to the login screen, they both freeze.

Any hints what might be the problem and what other steps I should take before taking it to the repair shop?

Thank you very much!

  • Try booting into Safe Mode. Hold Shift while booting until you hear the chime. You can also try Recovery Mode Cmd-R. Let us know if the kbd works by editing the original question with the results of your test.
    – Allan
    Commented Jun 19, 2017 at 11:18
  • Is there something connected on your USB ports?
    – dan
    Commented Jun 19, 2017 at 11:48
  • @danielAzuelos no nothing is attached.
    – ikechi
    Commented Jun 19, 2017 at 12:14
  • Sorry, meant to add to above, I could reset the PRam with the Keyboard but when OS X started up the keyboard wouldn't work ... Commented May 8, 2020 at 14:22

2 Answers 2


First off, you are running macOS Sierra on on an unsupported Mac. Per Apple's official supported hardware list, it supports MacBook Pros from 2010 and newer.

macOS Sierra was installed either by:

  • using some sort of "hack" to trick the installer into thinking it was supported hardware
  • installing it on a different MacBook Pro then moving drive with the new macOs installation into your MacBook Pro.

It's quite conceivable that this installation initially worked, but after an update, things would break because Apple is not anticipating that macOS Sierra is working on unsupported hardware.

The fact that it's working in a pre-boot environment, is a good sign that your hardware is good, though it's not conclusive. What you need to do is to revert back to El Capitan (10.11.x).

Run Internet Recovery CommandOptionR instead of booting from the Recovery partition. This will load the last supported OS. If your keyboard and trackpad works, then you have your answer.

What you will need to do next is to erase your drive and start with a fresh install of El Capitan.

  • Note: the keyboard is working at boot. I rather suspect a damaged USB kernel extension.
    – dan
    Commented Jun 19, 2017 at 12:34
  • @danielAzuelos - that scenario should be eliminated by booting into recovery as the USB kext there would be "pristine" compared to the one on the main boot partition. However, according to the OP, the problem still persists.
    – Allan
    Commented Jun 19, 2017 at 12:58
  • Just updated the original question.
    – ikechi
    Commented Jun 19, 2017 at 13:54
  • → @Allan: I agree with you, but the boot in recovery mode didn't work.[return] → ikechi: useful to get a better answer.
    – dan
    Commented Jun 19, 2017 at 14:21
  • @danielAzuelos - I think I know the issue. Sierra not supported on 2009 MBP.
    – Allan
    Commented Jun 19, 2017 at 14:26

I have 2 MacBook Pro's 2009. My keyboard and trackpad stopped working on one. Tried usual – resetting Pram and SMC – no result. I opened it to find the Trackpad Cable was damaged. I didn't want to start buying pieces for it when I wasn't sure if trackpad cable would have affected the keyboard as well – and online advice said it shouldn't – so I disconnected it on my other Macbook to find it wouldn't even start with the Trackpad cable disconnected ?? Anyway, to answer the question, I bought a new trackpad cable Online for €15, fitted it and all(trackpad AND Keyboard) are working again :) All the best! Seán

  • Another tip – I noticed the R,T,Y keys weren't working so I cleaned the cable connection – with Isopropyl Alcohol – at the point where it joined the Motherboard and all working now. Commented May 8, 2020 at 16:16

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .