2

I have an early 2013 Retina MacBook Pro running macOS Sierra 10.12.5 connected to an ViewSonic VX2478 monitor using a MiniDisplayPort cable connected to a ThunderBolt port. The monitor is detected correctly as having a default resolution of 2560x1440. However, when I set it to the default resolution the monitor claims to have no signal while macOS seems to think everything is fine. If I set the resolution to 1080p the display works fine.

When I started trying to make this work I had El Capitan instead of Sierra. The problem was slightly different. The monitor didn't display a "No Signal" error, but it didn't display anything, either.

I connected the display to my Windows laptop using its ThunderBolt port and the full native resolution worked fine.

I have tried the following:

  • Both a mini-DP to DP (included with the display) and a mini-DP to mini-DP cable (purchased new)
  • Reseting NVRAM
  • Reseting the SMC
  • Both Thunderbolt ports
  • Experimenting with various resolutions using SwitchResX
  • Disabling Automatic Graphics Switching

I haven't tried using an HDMI cable because I can't seem to find one lying around, and many of the solutions I've found to similar problems involve using a DisplayPort cable instead of an HDMI or DVI cable.

  • Did you solve this? – Matt Sephton Dec 2 '17 at 0:26
  • Yes, just a couple minutes ago. I used an HDMI cable. I think you just need to make sure it's a sufficiently new/good one. – Erik Engbrecht Dec 9 '17 at 15:38
0

I solved this problem by using an HDMI cable. Full resolution works fine. I still don't know why DisplayPort doesn't work at full resolution.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .