I have OS Sierra 10.12.5 on a MBP late 2016 - it's got the big beautiful trackpad. I love the trackpad, but I hate how it always clicks when I don't want it to.

I want a trackpad that only clicks when I actually click, not tap.

I have disabled all the extra tapping crap in prefs, including the haptic nonsense and extra clicking whatnot. All boxes are unchecked, and yet if I tap something, it still thinks it's a click.

  • 1
    Just to be clear: in System Preferences -> trackpad -> you have disabled "Tap to click"? – NoahL Jun 16 '17 at 16:04
  • Indeed I have, indeed I have. All three of those boxes are unchecked. In fact every single box in unchecked in all of the trackpad prefs except the Pinch In And Zoom Out one. – Disco Danny Jun 16 '17 at 21:57
  • Hey Noah - if you uncheck that box, does yours stop clicking on a single tap? – Disco Danny Jun 16 '17 at 21:57
  • Yes, BUT I have a 2013 rMBP, where the click is physical. Remember, because of the way your MBP is built (Force touch trackpad), the trackpad doesn't physically sink like mine does. Really, IIRC, the only thing that differentiates a rap from a click on your trackpad is the amount of pressure you apply. – NoahL Jun 16 '17 at 22:01
  • Huh! It does have a click though, very distinct. And the trackpad does depress slightly, though not as much as my 2012 MBP. Yes it's easy to click this but still it's way different than a tap. A tap is light and feathery, a click is a determined press. Am I completely off base on this? – Disco Danny Jun 16 '17 at 22:46

With the latest software update 10.12.6, the option to disable "tap to touch" works now. It's in the trackpad options. Before the update this did not work. Funny story - after the updating the OS (months ago?) it was still forcing the tapping. When I went into the trackpad options the box was unchecked, which didn't make sense. For fun I clicked and unclicked the box, and now it's fixed. Yay.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .