0

Well, basically I bought a good battery it was working fine, and lasting for a long time on a single charge. After like 40-50 cycles or so, I left it without charging and it drained to zero. Now, I can't charge the phone (I use wall charger). It shows only the battery red line sign and a cable, and when I plug it in, it only shows the red lining battery.

  1. I tried keeping it overnight on charging (I use wall charger, because I know it is stronger).

  2. I also tried going into DFU mode, but to no avail. No use. It can actually go to iTunes and iTunes detects the phone, and I can actually restore the phone, but after it finishes it resets and the same happens - red lining battery sign.

  3. I tried keeping the battery on red hot sun and after it almost melts from the heat I wait one minute to cool off and then I put it in phone, same result.

What else can I do?

| improve this question | | | | |
  • 1
    Send the battery back. – Tetsujin Jun 16 '17 at 13:01
  • You think it's bad for sure? I once had the same problem (actually I posted a question about it here on SO), and after 3 hours or so, it turned on. Thought it might be similar with this one though, seems like not. – Vladimir Despotovic Jun 16 '17 at 13:04
  • Well, either the battery's bad, the phone's bad, or the replacement job was bad. It's hard to do more than speculate. – Tetsujin Jun 16 '17 at 13:09
  • Have you tried a known good cable? I've had cables which looked physically OK, but which didn't work because of invisible flaws. – IconDaemon Jun 16 '17 at 13:21
  • Yeah, I tried a very good cable, and also an original one. I will give up any moment now and throw the battery away, and just buy a new one. I think the problem is battery, because I have another one which works fine, but is probably a Chinese copy, so drains much more quickly than that last one. Works anyway. – Vladimir Despotovic Jun 16 '17 at 13:37
0

As mentioned in comments, first check the cable is good.

After that, analysis isn't easy without the right tools.

Your potential fail-points are

  1. The battery's bad
  2. The phone's bad, or
  3. The installation wasn't done properly.
| improve this answer | | | | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .