4

Until now, only iOS devices purchased direct from an Apple sales channel could be added to the Device Enrollment Program (DEP). But at WWDC June 2017, Apple announced that any device running iOS 11 or tvOS 11 could be added to DEP. (The information is in this presentation - p25 of the PDF or around 05:20 in the video.) Although it wasn't stated explicitly, the slide implies that this requires Apple Configurator 2.5.

Is this functionality implemented yet in the beta releases of iOS 11/Apple Configurator 2.5? And if so, how do I use it?

What I've tried/found so far:

  • I've got a couple of devices (iPhone 5s, iPhone 6 Plus) running the current iOS 11 beta (build 15A5278f, 5 Jun 17) and a Mac running the current Apple Configurator 2.5 beta (build 3F12, 5 Jun 17) but I can't find a way to add either device to DEP.
  • If I connect an iOS 10 device to the Configurator I get exactly the same options (which indicates there's no special support for iOS 11 yet).
  • In the Prepare Devices screen there is an option Add to Device Enrollment Program which is disabled and can't be enabled:

enter image description here

  • How are you adding devices to DEP at present? – IconDaemon Jun 16 '17 at 12:25
  • We're not, it's a new project. – Mark Whitaker Jun 16 '17 at 14:59
  • 2
    It looks like it won't be rolled out until iOS 11 is officially released. You and I have probably read the statements about 'how easy it will be' to have the DEP functions, not 'how easy it is'. I, too, look forward to this ability. – IconDaemon Jun 16 '17 at 19:34
  • 1
    I can confirm what others are seeing. I'm getting an error in Apple Configurator 2.5 Beta saying it cannot find the Enrollment URL.. and I'm also getting an error on the DEP login window saying the "authentication failed" but I know damn well the AppleID and Password are correct. I have a convo going with a "Senior iOS Engineer".. and will post updates here if I get it working. (he seems to imply "it's Beta.. may not work".. but I don't wanna confirm that just yet until I get clarity from him. - jason – Jason Nugent Jun 30 '17 at 21:16
  • Any update with the iOS senior engineer on this? – NetConstructor.com Aug 24 '17 at 5:44
2

In the new beta 2.5 it's active but when you are on the step where you need to login to your DEP account I get an authentication error. I'm 100% sure I entered the right credentials: even used 2 DEP accounts and still not working.

  • Yes, I get exactly the same error with the new beta too. – Mark Whitaker Jun 28 '17 at 10:10

You must log in to answer this question.

protected by Community Jul 14 '17 at 11:25

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .