6

I click on the signature button in the Preview.app toolbar:

The following box pops up:

I click on the Click Here To Begin button. The box is now ready for input:

However, I cannot get any markings at all to show up as my signature. My box always looks like the above image.

I've tried doing the above in an image document and a PDF document. I've tried holding down the trackpad while writing and not holding the trackpad down while writing. I've tried using a mouse.

Is there a fix for this bug, so that I can use my Macbook trackpad to write my signature?

Note: the Camera-based signature method technically works on my machine. However, its rendition ability isn't great.


OS X El Capitan, version 10.11.6.


  • I know that I can create my signature in any number of other applications, so this bug is not a huge issue. I thought that I would make this post because I couldn't find a post about this bug online. – rubik's sphere Jun 16 '17 at 19:56
  • Ever find a solution? I'm having a similar problem, only with the "Camera" option. – Michael Dec 21 '17 at 23:02
  • 1
    Apparently some bug in Preview.app, happens even in High Sierra 10.13.4. Closing all open documents and relaunching Preview.app should fix the problem. – Nimesh Neema May 3 '18 at 5:28
  • The camera option worked fine for me. I'm running Htgh Sierra 10.13.6. – jmh Jul 29 '18 at 17:42
  • @rubik'ssphere ever found a solution? facing the same issue with MacOS Sierra 10.14.3 – zerohedge Apr 7 at 10:10
2

I had the same problem on 10.13.3 High Sierra. Rebooting the computer fixed the issue.

  • Sadly, a reboot (or 100) most definitely does not fix the issue on 10.11.6. – rubik's sphere Jun 6 '18 at 4:46
2

I stumbled across getting it working for the first time ever. I've tried using it several times with no success. What was different this time, was while the signature window was active but I hadn't yet clicked "Click here to begin", I accidentally clicked the 'text entry' tool that creates a textbox with default red ink. While that was active and accepting input, I then clicked "Click here to begin", and to my surprise it registered my trackpad signature.

Since I couldn't press a key to end the drawing (since the text box was still active and typing my keypresses), I canceled, exited textbox entry, and tried to register a signature again. This time it also worked.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .