The newer versions of iTerm2 have a "feature" in which a Search dialog is displayed instead of doing a Start selection action.

enter image description here

My intention had been to select the 14 and the following paragraph .. but instead I am presented with the Wikipedia lookup of the symbol 14. Not exactly what were on my mind ..

I have looked through all of the iTerm2 Preferences and not found anything to disable this behavior. Anyone have better eyes than me on this?

3 Answers 3


You can disable this feature by opening iTerm2 preferences, then search for "dictionary". You can navigate to this preference by opening preferences, clicking "Advanced", and then scrolling through the list until you see "General" and "Perform dictionary lookups on force press".

You don't need to restart iTerm2 for this change to take effect.

This was tested while using macOS Catalina with iTerm2 3.3.6. I have "force click and haptic feedback" disabled in the system's Trackpad Point & Click settings.

enter image description here


Disable "Force Click and haptic feedback" in System Preferences > Trackpad.


In case anyone is still seeing this, iTerm2 3.3.6 has a bug which can cause the popup still to appear even with both parts of dpk's answer applied (that is, with Force Click disabled, as well as Perform dictionary lookups set to No).


I am one of the people that this fails to fix it for. (I'm on Mojave 10.14.6 on a 2017 15" MBP, fwiw.)

As per the issue page, another fix was put in place in 3.3.7 (the latest release version at time of writing), but apparently even that hasn't fixed it for everyone. The latest beta of 3.3.8 has another go at fixing it.

I just found the above issue, and have not yet tried 3.3.7 or the 3.3.8 beta to see if it fixes it for me. This is the most annoying feature of my Mac by far, so I will probably try the 3.3.8 beta soon, and I'll report back here if I do (and when 3.3.8 exits beta.)


Apparently I forgot to report back in a timely manner. Something about a novel virus? ... 3.3.8 beta did indeed fix it. Now I'm on 3.3.11 (and Catalina) and no signs of regressions, so well done team iTerm2. Third time was a charm.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .