6

The newer versions of iTerm2 have a "feature" in which a Search dialog is displayed instead of doing a Start selection action.

enter image description here

My intention had been to select the 14 and the following paragraph .. but instead I am presented with the Wikipedia lookup of the symbol 14. Not exactly what were on my mind ..

I have looked through all of the iTerm2 Preferences and not found anything to disable this behavior. Anyone have better eyes than me on this?

3

You can disable this feature by opening iTerm2 preferences, then search for "dictionary". You can navigate to this preference by opening preferences, clicking "Advanced", and then scrolling through the list until you see "General" and "Perform dictionary lookups on force press".

You don't need to restart iTerm2 for this change to take effect.

This was tested while using macOS Catalina with iTerm2 3.3.6. I have "force click and haptic feedback" disabled in the system's Trackpad Point & Click settings.

enter image description here

3

Disable "Force Click and haptic feedback" in System Preferences > Trackpad.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .