1

So, a couple weeks ago I went to wake my computer up and the screen just stayed black. Strangely I could feel clicks in the touch pad (which means there is power and the haptic engine is working) but absolutely nothing else. I tried literally all day, to charge it, uncharge it, pressed the power button 1000 different ways and then nothing. So I got an idea:

I opened up the computer and unplugged the battery. Then I plugged in the power... Instantly it boots up. It gets stuck in a loop of half loading, crashing and then starting again. So at this point I plug the battery in and everything boots up and seems good. Except... now the keyboard doesn't work.

So for almost a week I used an external USB keyboard with my computer, scared to death to let it shut down. Then one day... the keyboard just started working again, everything except the arrow keys and the question mark. The arrow keys came back the next day after randomly pressing themselves a bunch, the question mark never did.

Anyways, I was OK with my situation, copy pasting a question mark in from the notepad when I needed it. But now this morning I had the black screen again. This time nothing worked at all, except there was music playing and I could turn the volume up and down and skip songs, but nothing else worked (not the keyboard lights, not the power button)... so I unplugged the battery and jump started it again.

Now my command keys don't work.

This is getting incredibly frustrating and I am appalled that this $3000+ machine has so many strange random problems that have nothing to do with physical damage.

Does anyone have any idea what's going on?

  • I have to agree with @LexS that the most likely culprit is a battery. If you have AppleCare coverage, I would take it in straight away. Also, have a look at this answer for more details. – Allan Jun 14 '17 at 21:51
1

If you still have AppleCare coverage I would contact Apple for support and disregard the rest of this answer

There are a few things you could try to troubleshoot this - but you will need to be patient as troubleshooting is often a process of elimination and takes time.

For starters, I'd do a NVRAM and SMC reset (in that order). Before following the steps below, ensure you have no external hardware connected and that you're using the built-in keyboard.

Reset the NVRAM

Reset the NVRAM on your MBP as follows:

  1. Shut down your machine. Yes, a full shut down, not just logging out.
  2. Press the power button and then press the commandoptionpr keys. You have to make sure you press these keys before the gray screen appears or it won’t work.
  3. Hold those keys down until your MBP reboots again and you here the startup chime.
  4. Let go of the keys and let your MBP reboot normally.

Note: When you log back in you may need to readjust some of your system preferences (e.g. speaker volume, screen resolution, startup disk selection, time zone information, etc).

Reset the SMC

There's a couple of ways you can reset the SMC on your MBP, however I prefer the following steps:

  1. Shut down your MBP
  2. Keep the power cable plugged in
  3. Press at the same time shiftoptioncontrol (on the left side of the keyboard) and the power button
  4. Let go
  5. Turn your computer back on with the power button

After resetting both the NVRAM and SMC, use your computer to determine if the issues still persist.

If you're still having problems, the it's time to test your hardware with Apple Diagnostics.

Run Apple Diagnostics

Follow the steps below to run Apple Diagnostics:

  1. Fully shut down your Mac
  2. Restart your Mac
  3. Immediately press the D key and keep it down until you see the Diagnostics screen appear
  4. Wait for Diagnostics to finish (this typically only takes a few minutes)
  5. Once complete, one of two things will appear on the screen:
    • a No issues found message
    • a brief description of any errors found plus further instructions
  6. If the diagnostics test does find errors, take a note of what they are

Note: If pressing and holding the D key at Step 3 doesn't work, start again at Step 1 and, at Step 3 press and hold both the OptionD keys instead. This will try and run diagnostics from the internet instead, so you will need to allow more time for it to complete.

Regardless, take a note of what happens and let me know how you went.

0

It looks like a faulty battery that has swollen a bit. Try another battery.

  • We're trying to find the best answers and those answers will provide info as to why they're the best. Answers should be self-contained so explain why you think the answer you provided will solve the problem or is better than others out there. Providing links as supporting information can also help the OP, and others, find additional info for themselves. See How to Answer on how to provide a quality answer. - From Review – fsb Jun 14 '17 at 21:14

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .