1

I have an Early 2011 Macbook Pro. I need to access the recovery partition for several reasons, such as turning off "SIP". Until now, every time I pressed CMD+R during booting, it went directly to the internet recovery mode. That has never been a problem for me until now. As you can see from this picture the partition exists : diskutil list

However, not only it doesn't start with CMD+R. It also doesn't show as an option when I press opt . So I went in disk utility, run first aid and got the following output :diskutil

So I followed the instructions, went to (internet) recovery mode once again, and tried to fix it. Now this is the interesting part, according to the disk utility on internet recovery mode, there are no problems.

However, when I tried to mount the recovery partition (disk0s3) it failed. I also tried to reset the PRAM, but nothing changed.

I'm trying everything I can that doesn't involve reinstalling the OS, as last time I did that it took forever to copy my backup. However, I'm running out of ideas at this point.

If you have any suggestion and if you think you know what might be causing this, I would really appreciate it if you could let me know.

Thanks in advance!

1

At this point you've ruled out all of the basic things. Reinstalling macOS, even from within the Macintosh HD should reinstall or repair the Recovery HD.

Additionally you should be able to disable SIP from Single User Mode in the meantime.

  • Are you sure? How do I disable SIP from Single User Mode? - Thanks – Giulio Colleluori Jun 14 '17 at 1:31

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .