7

I have been a Windows user my whole life and just purchased my very first Apple product ever: a MBP.

I have a question regarding Finder, which may be a bug or simply me who doesn't know how to use it properly.

Anyways, here's the (potential) problem: when I am using Finder in split screen mode sometimes folders and files are overlapped by the upper menu.

Check this out: enter image description here

As you can see in the image above, some folders are now 'under' the upper menu and I cannot seem to be able to get them back in 'visible' positions.

Can someone advise if this is a bug or it's just me being newbie?

Thanks :)

--- UPDATE

I am on MacOS 10.12.5 - the scroll bar is 'fully scrolled up' already.

I can't drag folders or files - when I release the mouse button, they simply stay in their original position.

The problem occurs in all folder view modes.

--- UPDATE II

I don't have 'none' or 'snap to grid' as options in the 'sort by' dropdown: enter image description here

Or in the 'arrange by' dropdown: enter image description here

The 'clean up' entries in the view menu are disabled: enter image description here

One thing I forgot to mention: the sidebar also gets 'swallowed' by the upper menu: enter image description here

'Documents', 'Desktop', 'Google Drive', 'Air Drop', etc., are also hidden by the upper menu.

  • 1) Welcome to Ask Different? 2) What version of MacOS are you running? 3) Can you not scroll up to it? If you can't, can you drag the folders down by selecting them with the mouse and grabbing the bottom parts of the folder names? Does the same problem occur in the other folder views (viewable with the four buttons directly above the "Quebec" folder)? – NoahL Jun 13 '17 at 20:23
  • 1) Thanks 2) MacOS 10.12.5 3) Nope - it's 'fully scrolled up' already. I can't drag it either. When I release the mouse button, it simply stays in its original place. Yes, the problem occurs in all folder views. – cldjr Jun 13 '17 at 20:27
  • 1
    Where are you trying to drag it to? A random place in the same window? (If you have 'snap to grid' turned on in the view options, it will snap back). From the screenshot, it looks as if the window is fully scrolled down - you're looking at the last line of your folder (I'm going by the list of items in your sidebar) - try scrolling in the other direction. (You can set the scroll direction in System Preferences). – green_knight Jun 16 '17 at 9:17
  • Yes, to the same window. I am not sure whether or not 'snap to grid' is active - I will check this evening. I was suggested to deactivate it in the answer below as well. – cldjr Jun 16 '17 at 9:19
  • I am totally sure about the scroll bar. I've tried to scroll it in every imaginable direction - up, down, sideways, diagonal - and it didn't work. Actually an interesting thing to add here is, the scroll bar is also overlapped by the upper menu. When the scroll bar is fully up, the 'sliding bar' (that thing that goes up and down, whatever it's called) gets 'swallowed' by the upper menu as well. – cldjr Jun 16 '17 at 9:21
4
+50

It's most likely a Problem with automatic sorting and cleanup in the Grid Display. Look at the general Info Pages from Apple Support here and here about customizing your Display Settings.

In Short: Right-click (if it is activated) on the Finder Window and change the 'sort by' Option and activate the cleanup. You probably have the Option 'Snap to Grid' activated - try deactivating it.

-- Addendum --

As a second option, try deleting the '.DS_Store'-Files, which store Icon Positions and Images (see further explanation here). If that doesn't help there are a few other possibilities, but let's start with the easiest one

Like all Files starting with a dot [.] these are invisible. You have to use the Terminal.app, found in /Applications/Utilities/ do remove them. Technically, you need only remove the .DS_Store-File in the Folder "Canada" according to your Screenshot.

Open the Terminal and navigate to the Folder, f.e. within 'Documents'

cd /Users/yourusername/Documents/Canada

hit enter, the type

rm .DS_Store

You should close the Folder "Canada" and then reopen it again. The Icon and Sidebar Position should be normal.

  • I am not home now so I can't test your answer (I will do it tonight) - however I have tried to change the 'sort by' logic - folder and files were rearranged but the files in the first row remained under the upper menu. I read the problem could be related to 'snap to grid' - I checked the sort by menu and there is no 'snap to grid' option there. I will try and find the 'snap to grid' option to deactivate it and activate the cleanup to see if fixes the problem. Thanks J.C. – cldjr Jun 16 '17 at 8:52
  • Clean up menu entry is disabled - I read I need to disable automatic sorting but in the sort by dropbox I don't have the none option. Also, the option 'Snap to Grid' is nowhere to be found - not in the sort or arrange by menus. What am I missing here? – cldjr Jun 16 '17 at 17:03
  • I have troubles understanding your answer. Could you make a Screenshot of the Context Menu (and all of the current settings) and post it here? – J.C. Jun 17 '17 at 5:08
  • I added a few screenshots - hope it helps – cldjr Jun 17 '17 at 9:25
  • Deleting .DS_Store under Canada fixed not only the folder Canada itself but also the sidebar and all other folders. I split the screen multiple times with Finder loaded in a random folder + Pages or Chrome and they all worked as a charm. Maybe DS_Store of the Canada folder was corrupted or something and messed the Finder mechanism responsible for laying objects on the screen. I don't know, just guessing really. Anyways, thanks a lot J.C. That was absolutely brilliant. – cldjr Jun 21 '17 at 17:58
4

I noticed the same thing just now when I tried to duplicate your issue. Also running 10.12.5.

I was able to get rid of the problem by:

  1. Turning the Tab Bar* off.
  2. Turning the Status Bar on.
  3. Resizing the icons with the slider in the Status Bar.

This caused the folders to move into the correct positions.

* The issue showed up with or without the Tab Bar, so I don't know if it is involved with the bug or not.

  • Awesome, thanks! It worked when I resized with the icons with slider in the status bar - I made the files bigger and moved back into 'visible' positions. However, the sidebar continues truncated - its top remains under the upper menu - do you know how to fix that? – cldjr Jun 17 '17 at 9:15
  • @cldjr I was able to get rid of that by: backing out of Split View, hiding the Toolbar (Cmd-Opt-T or View > Hide Toolbar), re-entering Split View, then backing out again, reenabling the Toolbar, and re-re-entering Split View. Not exactly the handiest method. – Celsius1414 Jun 17 '17 at 15:26

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .