The keys that were supposed to give tilde and back-tick in the keyboard are giving § ±, respectively. My input source is U.S, as you can see in the image, and my keyboard layout is the following: keyboard layout enter image description here

I tried to format my mac but it didn't work as well. What's is the problem that is occurring? Is there a way it can be solved?

Thank you!


It looks like your machine thinks the keyboard is of the ISO type instead of the ANSI type. ISO keyboards have tilde/backtick on an extra key next to the Z. See if this note can help:

  • Thank you, unfortunately there is no keyboardtype.plist in my Library/Preferences. I ran /System/Library/CoreServices/KeyboardSetupAssistant.app/Contents/MacOS/KeyboardSetupAssistant and nothing's happened. Finnaly I tried to reset the SMC, but again it didn't work. Jun 12 '17 at 22:40
  • @EduardoHashimoto In addition to karabiner, you could make a custom layout with scripts.sil.org/ukelele Jun 12 '17 at 22:57

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .