0

I recently created 2 small partitions, and after that, I shutdown my Mac. Then when I turned Mac back on today it took awhile to boot and then showed a blocked symbol.

I tried booting into the recovery partition. Then I deleted the partition, which is 10 GB in size, but I'm not able to delete the second partition, which is 15 GB. Also, when I tried creating the partitions before, it showed "Operation failed".

After some time, two partitions showed up, both named -- and greyed out. Macintosh HD no longer shows up in Disk Utility. Only some weird disk image shows up as OS X Base System.

I tried to reinstall macOS Sierra but the Macintosh HD partition again does not show up. I tried First Aid but it shows Macintosh is corrupted and needs to be recovered in Recovery, but I booted in the recovery partition only.

So how do I make my mac boot up normally and delete the 15GB partition without losing any data and erasing my HD.

macOS Sierra 10.12.5

And is this problem a serious issue or not?

Output of gpt -r show disk0 per klanomath's request:

start       size  index  contents
          0          1         PMBR
          1          1         Pri GPT header
          2         32         Pri GPT table
         34          6         
         40     409600      1  GPT part - C12A7328-F81F-11D2-BA4B-00A0C93EC93B
     409640  205318496      2  GPT part - 53746F72-6167-11AA-AA11-00306543ECAC
  205728136    1269536      3  GPT part - 426F6F74-0000-11AA-AA11-00306543ECAC
  206997672   29718320      4  GPT part - 48465300-0000-11AA-AA11-00306543ECAC
  236715992     262151         
  236978143         32         Sec GPT table
  236978175          1         Sec GPT header
  • How did you create the partitions? What command or utility did you use? – William T Froggard Jun 11 '17 at 5:12
  • I used disk utility – user238552 Jun 11 '17 at 5:13

You must log in to answer this question.