1

From terminal I see that PreventUserIdleSystemSleep assertion takes 15 second before actually sleep. Is there any way to eliminate it, or at least set delay to 0/1 sec?

2017-06-09 23:36:15 +0500 Notification Display is turned off
2017-06-09 23:36:15 +0500 Assertions PID 603(AddressBookSourceSync) Summary PreventUserIdleSystemSleep "Address Book Source Sync" 00:00:07 id:0x0x100000185 [System: PrevIdle]
2017-06-09 23:36:15 +0500 Assertions Kernel Idle sleep preventers: -None-
2017-06-09 23:36:15 +0500 Assertions PID 52(powerd) Created InternalPreventSleep "com.apple.powermanagement.darkwakelinger" 00:00:00 id:0x0xd0000018a [System: PrevIdle SRPrevSleep kCPU]
2017-06-09 23:36:20 +0500 Assertions Kernel Idle sleep preventers: IODisplayWrangler
2017-06-09 23:36:20 +0500 Notification Display is turned on
2017-06-09 23:36:30 +0500 Assertions PID 52(powerd) TimedOut InternalPreventSleep "com.apple.powermanagement.darkwakelinger" 00:00:15 id:0x0xd0000018a [System: PrevIdle SRPrevSleep kCPU]

0

There's an (apparently undocumented) option in pmset to adjust the "dark wake linger" interval.

sudo pmset dwlinterval <seconds>

However, I would recommend against changing the default without a good reason.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .