0

Macbook --> Thunderbolt Ethernet adapter --> Ethernet Cable --> Device under test with IP address

The device under test is not connected to the internet. While I am testing the device I still need an internet connection, but the non internet device connected with the Thunderbolt Ethernet adapter takes over and I cannot connect to the internet through wifi.

  • Maybe I get you wrong, but I am wondering why this should not work? At work I have my MBP connected to the LAN via a Thunderbolt Dock with an ethernet port, though I am able to enable/disable wifi and to use the internet via wifi. – northsea Jun 8 '17 at 20:49
  • @northsea Your setup shouldn't work, as far as I know. I've noticed the same thing that macOS prefers the wired connection if it's available. If you're connected to the LAN, you may be getting an internet connection from there. – William T Froggard Jun 8 '17 at 23:35
  • @WilliamTFroggard Hm... maybe. I will check that on Monday morning. – northsea Jun 9 '17 at 8:40
  • @WilliamTFroggard No it works. See my answer – northsea Jun 19 '17 at 9:51
2
  1. Choose Apple menu > System Preferences, then click Network. In the list on the left, you see the connections/services.

  2. Click the Action pop-up menu at the bottom, then choose Set Service Order.

    enter image description here

  3. Drag a service, in your case WiFi, to the top of the list.

    enter image description here

  4. Click OK, then click Apply to make the new settings active.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .