the "a" button is busted and behaves as if it's constantly being pressed down. I have a wired keyboard ready to use but I can't figure out how to turn off the keyboard here. I tried Control + F1 after enabling "Use all F1, F2, etc keys as standard function keys" but that's not doing anything.

This "a" problem is making it incredibly difficult to code.

2 Answers 2


I would recommend Karabiner Elements. It's the successor to Karabiner, and works on macOS Sierra. There's an option under the devices menu to disable the build-in keyboard while another keyboard is selected, which should do exactly what you want.

enter image description here


You can try 2 options

  1. This free app KeyboardCleanTool, I do not have an external keyboard so I don't know if it disables too.
  2. Running the following commands.

    • Disable:

      sudo kextunload /System/Library/Extensions/AppleUSBTopCase.kext/Contents/PlugIns/AppleUSBTCKeyboard.kext/
    • Enable:

      sudo kextload /System/Library/Extensions/AppleUSBTopCase.kext/Contents/PlugIns/AppleUSBTCKeyboard.kext/

Although when you disable the keyboard the following message shows up, the keyboard remains disabled:

(kernel) Can't unload kext com.apple.driver.AppleUSBTCKeyboard; classes have instances:
(kernel)     Kext com.apple.driver.AppleUSBTCKeyboard class AppleUSBTCKeyboard has 1 instance.
Failed to unload com.apple.driver.AppleUSBTCKeyboard - (libkern/kext) kext is in use or retained (cannot unload).

I tried both options and both work.

Note: Consider that those commands should be running as administrator, the sudo command "saves" password for a limited time and you can run other commands between this timespan, but when the time is over the terminal asks for the password again and if you do not have an external keyboard you can not type the password until you restart the macbook.

Source: This post answers

  • By the way I'm using macOS Sierra 10.12.5
    – ybrajim
    Jun 8, 2017 at 20:46

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .