0

I'm using my macbook pro with an international Spanish PC keyboard and am trying in vain to find the tilde '~' character. I've tried the layouts "British - PC" and "U.S. International - PC" but cant figure out how to get that tilde to show.

On the U.S. layout, when I press the key between left-shift and Z, I get the back tick '`'. When I use shift, I get '˜'. With the option key I get a back tick as well.

On the British layout, when I press the button below escape I get the back tick, but with shift I get "¬". With the option key I get '¦'.

Anyone know what I need to press?

In response to the possible duplicate:

The answer given for the question about the tilde with a Spanish keyboard does, indeed mention that you can use alt+n and then / to type the tilde on English layouts, but as Tom Gewecke pointed out, that is not true for all English layouts as the other question seems to suggest. The answers here are more specific and helpful.

2

On U.S. International - PC layout, press Alt-N and then Space

How to find keys in General

  • Go to Preferences->Keyboard Preferences
  • Input Sources
  • Check "Show input menu in menu bar"
  • Click on the flag in the top menu bar
  • Show keyboard viewer
  • Look for "~"
  • Press Shift, look for ~
  • Press Alt, look for ~
  • Press Shift+Alt, look for ~
  • Thanks for that. I had looked at the keyboard preferences but didn't know about pressing shift and alt to see different characters. In any case the tilde doesn't appear with either shift or alt there. never woulda guessed you have to press space after alt+N. I'll have to see if I can find an easier solution – Chris Jun 8 '17 at 10:40
  • I don't remember the spanish keyboard exactly, i have one in my flat in spain only. You can also check the key next to the left shift key with modifiers but most likely will have to press space afterwards as well. – user2707001 Jun 8 '17 at 10:42
  • I know how to do it on the Spanish layout, but I hardly ever use that layout while working in the terminal where I occasionally need the tilde – Chris Jun 8 '17 at 10:44
  • And you don't have to press space always... you can also press enter or e.g. /. If you type in a path like ~/dev, you can do so without pressing space (and this is, after all, the most common use for ~). (Just realized that when trying out how i usually do it. I wasn't aware of that :)) – user2707001 Jun 8 '17 at 10:44
  • This answer is wrong regarding the US layout. If you press alt n and then space, you get ˜, which is not ~. You have to change "US" to "US International PC" for it to be correct. – Tom Gewecke Jun 8 '17 at 10:59
2

On the US International PC layout, you press shift on the key next to the Z and then space. Or Option/alt n and then space.

On the British PC layout, you press shift on the key in the asdf row to the left of the return key.

On a Mac Spanish keyboard, with Spanish ISO input source active, you press option-alt on the key printed ñ, and then space.

On the US or British layout (which are quite different from US International PC and British PC), you press shift on the key next to the Z.

  • Thanks, already accepted the above answer but I appreciate the help – Chris Jun 8 '17 at 10:45
  • The accepted answer is actually wrong regarding the US layout, which is different from US International PC. – Tom Gewecke Jun 8 '17 at 11:00
  • .. but if you read the TO question it sais "U.S. International - PC"... – user2707001 Jun 8 '17 at 12:43
  • @user2707001 t US and US International PC are totally different layouts, and the answer is different depending on which one you are using. – Tom Gewecke Jun 8 '17 at 13:39

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.