I am a long time Apple Mac user since the 1990s, and I have never come across this sort of ridiculous behaviour before.

Yesterday I decided to reinstall macOS Sierra on my iMac. I followed these steps:

  1. I used Command-R to boot into macOS Recovery.
  2. I selected Disk Utility from the macOS Utilities window.
  3. I opted to erase the HD with a 2 pass secure erase. This was successful.
  4. I quit Disk Utility.
  5. I selected Reinstall macOS from the macOS Utilities window.
  6. I clicked continue when it told me to click ‘continue’ to set up the installation.
  7. I clicked continue again when it told me to click ‘continue’ to download and restore macOS
  8. And now I’m back at Step 6 again and get stuck in a loop between steps 6 & 7.

I have tried the above steps again today with the exact same result. Below is a visual representation of this madness:

enter image description here

Also, clicking on 'continue' instantly displays the next/previous screen - there is no indication that anything else is happening - not even the apparent eligibility check.

How do I get out of this looping hell?

I did read installation stuck in a loop due to damaged HD and Mac OS X Sierra installation stuck in a reboot loop but neither is about the same looping scenario as I find myself in.

  • If you are a newer Mac device (2011+) try booting into internet recovery mode and install that way?
    – user244412
    Jul 22 '17 at 2:56

This is the type of UX pain that really irks me, and very unlike Apple.

Since you're a long time Mac user I'm going to assume you have access to another Mac, so my suggestion would be to try reinstalling a fresh version of macOS Sierra via a USB installer.

Follow the steps below:

  1. On another Mac, download the macOS Sierra installer via the Mac App Store
  2. After its downloaded, the installer will launch automatically. When it does, quit the installer.
  3. Grab a USB flash drive of at least 8GB in size
  4. Connect the USB flash drive to the same Mac
  5. Rename the flash drive to Untitled
  6. Launch the Terminal app
  7. Now enter the following command into Terminal. It may be best to just copy it from here (try triple-clicking) and paste it in.

    sudo /Applications/Install\ macOS\ Sierra.app/Contents/Resources/createinstallmedia --volume /Volumes/Untitled --applicationpath /Applications/Install\ macOS\ Sierra.app

  8. You will be prompted to enter your user password. Enter it now and press return (note that you won’t see the cursor move or display any of the characters you enter)

  9. At the next prompt (about erasing your drive) press the Y key
  10. Wait for your USB flash drive to be erased (you’ll see the progress via % values appearing within the Terminal window)
  11. Once the erasure is complete, you will see a prompt that files are being copied to the disk. This may take a while, so be patient.
  12. Eventually the copy process will be over and you should see a Done message in Terminal. You can now quit Terminal.
  13. Eject the USB flash drive and now connect it to your iMac (the one you want to reinstall macOS Sierra on)
  14. Startup the iMac holding down the option key
  15. Select the USB flash drive you created from the list of drives and press enter

You should now be able to boot from the USB drive and install macOS Sierra from there.

Let me know if you have any questions.


I had same issue but after connecting to wifi I was able to continue!

  • This was the (much quicker) fix for me. I totally missed the "disconnected wifi logo" in the top-right until this comment prompted me to look for it.
    – Lanny Bose
    Jul 12 '17 at 16:03
  • 1
    I just want to say massive thanks for @LannyBose 's comment, this saved my life when up against the exact same issue. I was nearly ready to call out an imac doctor!! Reading these threads online are so helpful! Cheers Jul 30 '17 at 22:06

I just had this issue with High Sierra Beta 4 installation, after about 6-7 loops on APFS file system, I erased my hard disk from Disk Utility and made new partition with HFS+ Journaled file system, then it went through.

Funny thing is, after installation is done, it says that my file system is APFS.

  • 1
    Same thing here. Chose APFS and got stuck in a loop with errors in the console. Went back and chose HFS+ and it worked just fine.
    – rcd
    Nov 16 '17 at 3:41

I had this same exact issue. If you look in the upper right corner, you need to connect to your Wifi network. Once connected, when you click Continue on step 7, the installer will continue.

Very frustrating Apple didn't give better error messages.


I'm sure you started your computer by now... for anyone new coming to this page, I was able to fix mine after the same thing happened in a much easier way than the best answer. All I did was restart, hold down option-r, and it gives a dialog asking whether you wanna start the installer (default), or start your normal hard drive. Just select your hard drive instead, then head into the app store and try to re-install the update from there.


I also had this and it was the wifi just needed reconnecting to allow verification. .

  • Hi Ray, and welcome to Ask Different! Could you please elaborate a little more on your answer. On this site, the best answers that get upvoted the most tend to be longer and have descriptions and sources. Low-quality content may be deleted if it is downvoted. Learn more about writing great answers here. Thanks, and happy answering! Jul 21 '17 at 23:01

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .