I've not been able to save new passwords to my keychain lately.

In addition, I can't view any of my passwords. I'll open Keychain Access, pick a login entry, click the Show Password checkbox, and enter my account password. When I do this, I get an error message:

not authorized

This is really weird considering my account is an Admin user:

I'm an admin!

Keychain Access isn't my main password repository so I don't really care if I need to reset it. I tried going into Keychain Access to reset my default keychain. trying to reset

When I do this I receive the error message:


Like I said, I'm an admin for my computer. There is another admin account that was setup when this computer was imaged, but that account shouldn't own my keychain, right?!

I tried looking for Keychain First Aid but apparently that's been removed.

I'm running 10.12.4.

Any ideas of what's going on and/or how to fix it?

  • 1
    Are you able to see your keychain if you run security dump-keychain -d login.keychain in Terminal? If it fails, what is the error message?
    – grg
    Commented Jun 7, 2017 at 21:21
  • 1
    Hmm, so it looks like i have a mix of what I'm assuming is correct data being spit out (keychain paths, version, class, attributes, and data) and then from time to time the error message: security: SecKeychainItemCopyAttributesAndData: The user name or passphrase you entered is not correct. Commented Jun 7, 2017 at 21:30
  • 1
    Do you not get a prompt like this? When I run that command, if I click Deny, the error message you mention is printed for that item.
    – grg
    Commented Jun 7, 2017 at 21:41
  • Sorry, I missed this reply yesterday. No I didn't get a prompt like that. It just started dumping text into the terminal. Commented Jun 8, 2017 at 19:45
  • I second that question. Having the same problem with Mohave on an newish iMac (less than one year). Any rate, I did change my password and forgot it and so have to reset the default "login" and iCloud keychains. So first, I disable the keychain connection in the MacOS iCloud settings and then attempt to reset and get the prompt to enter my login password (maybe it means my "login" keychain password but obviously, I lost that (or have it narrowed down to still too many to attempt by non-automated brute force, so ..) willing to take the hit and (re)start with an empty keychain but sort of a catc
    – Josef
    Commented Mar 14, 2019 at 20:51

2 Answers 2


I was able to fix this issue by restarting my computer in recovery mode and using disk utility's First Aid to repair all volumes and the disk itself. I don't know which repair actually fixed the issue, but when I restarted I was able to view and save items in my keychain.

You can enter recovery mode by restarting your computer and holding down the keys command and r. Once you're in recovery mode you can select "Disk Utility" to get to the First Aid tool.

enter image description here

Once you're here you can click on each of the volumes (the indented names on the left. E.g. Macintosh HD) and then click the First Aid button.

I repaired both of my volumes and the disk itself (the APPLE SSD SM...). The first aids for the volumes and the disk itself do different things.

After you're done, restart your computer and try to use/view your keychain. Cross your fingers and hope you don't have to do more googling!

  • 1
    not on mac os high sierra Commented Mar 3, 2018 at 16:53
  • Worked perfectly in Mojave 10.14.4. Many many thanks!
    – fedorqui
    Commented Apr 7, 2020 at 12:24
  • worked on mojave Commented Oct 14, 2020 at 16:46

Running Disk Util also fixed this exact same problem for me. I have 10.12.6 that was working fine, until I came in to work one morning and suddenly nothing worked - Box and several other services kept demanding authentication and failing, claiming they could not access keychain. Trying to reset keychain resulted in same problems shown above in this post. Surprisingly, Disk Utility fixed it all.

  • 3
    What about running Disk Util fixed it for you? This is like saying "Running Word solved my problem with my letter to the bank." Disk Utility is the program with a number of functions.
    – Allan
    Commented Apr 18, 2018 at 20:39
  • 2
    Out of the blue, Garmin Express, said it could not authorize and would not let me reauthorize (enter user id/password) complaining about lack of keychain access. Somehow, the keychain was messed up even though I had not changed my password. I had the same issue (running 10.14.5 Mojave) - attempting to reset keychain resulted in "Unable to obtain authorization for this operation". I ran Disk Util, selected the first aid option, and let it do its thing. Then keychain and Garmin Express (after re-auth) were happy again.
    – Bill Hoag
    Commented Jul 12, 2019 at 15:25
  • @Allan I think he means "run first Aid on the disk on which macOS is installed". This actually seems to have worked for me.
    – Pertinax
    Commented Feb 10, 2022 at 20:49

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .