2

I don't know why, but there are some very strange problems with my system. At times, the right click will stop working on both the mouse and trackpad, only ctrl+click will work.

At the same time when pointing the mouse in the corner, it doesn't respond well. If I move the mouse over an icon in the dock, The dock will freeze, with the app icon stay "magnified". If I move the pointer over the dock, that icon stay larger.

I can click on any other icon, that don't move ( enlarge ) as usual and the app can be open.

I figured the only solution is to reinstall Sierra. (But, wait for it...)

I try to come back with Time Machine...nothing. Disk Utility...nothing. Bitdefender Virus and Malware scan...nothing. I've tried to reinstall the MacOS but after two days the problem appears again.

I've tried to not use some applications in the background, but until now I can't understand if some of that cause the problem.

What can I do to determine and understand if there are some app that is causing the problem or if it's just my settings and data reacting badly with the code and system?

5
  • could you please tell us your version, and what computer you are using? - From Review
    – bret7600
    Commented Jun 7, 2017 at 17:10
  • Sorry I use MacOS Sierra 10.12.5 (16F73) MacBook Pro (Retina, 15-inch, Mid 2015) 2,5 GHz Intel Core i7 16 GB 1600 MHz DDR3 Intel Iris Pro 1536 MB Commented Jun 7, 2017 at 20:45
  • I've just noticed another issue. Usually if i click on File in the menu bar and move the mouse to choose an option , every option become selected. If the pointer go over , for example Open File..., it become blue for selected. When i have the problem, this doesn't happen. When i move over an option, that don't highlight . I know the is very difficult to explain Commented Jun 7, 2017 at 20:52
  • I want to add another information. After many try i've noticed that the problem start after a wake up from sleep mode. PLS i need some suggestion Commented Jun 9, 2017 at 17:59
  • Do you have a bluetooth mouse? Disconnecting my Logitech bluetooth mouse fixed the problem immediately.
    – FilippoG
    Commented Aug 17, 2018 at 10:43

1 Answer 1

1

Found this in SuperUser:

It looks like your dock has died. If you can get into Terminal (Applications > Utilities > Terminal, I think), try sudo killall Dock. This'll crash-close the Dock, and it should restart happily. If it doesn't, logout and back in again.

2
  • Please give credit where credit is due.
    – nohillside
    Commented Dec 12, 2017 at 18:09
  • Dock restarts bu problems are exactly the same.
    – FilippoG
    Commented Aug 17, 2018 at 10:08

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .