I've installed the macOS Developer Beta Access Utility (.pkg file) from Apple Developer's official website. Upon completing installation, it opens the Mac App Store to the macOS High Sierra installation page automatically.

Image 1

Under the 'Information' section, it's stated that the size of the installation file is 4.90 GB.

Image 2

However, when I downloaded it, it didn't download the full installation file. Instead, it's only 7.8 MB large.

Image 3

The installation file looks the same as a usual one.

Image 4


  • Why are some users getting the 4.90 GB file while others are getting the 7.8 MB file?

  • Is there any way to get the full 4.90 GB installation file?

Fyi, my Mac is currently running on macOS Sierra 10.12.3 (16D32).


I appreciate the two answers that I've received and both can be reproduced. However, I'm not sure on why are some users getting the 4.90 GB file while others are getting the 7.8 MB file.

This thread from MacRumours suggests that it's something to do with the amount of disk space available on the Mac.

6 Answers 6


For what it's worth: I have encountered a similar issue: a very small download file (14,5 MB), that launched automatically after a few seconds... tried it twice (both times the installation failed giving me some error about corrupted information on the server - I'm not sure what it meant but it might have been related to the fact that I was logged onto the MAS with a different account than the one I signed up for the public beta with). Anyway I just retried again and just on a whim before clicking download I pressed alt on the keyboard... now it's downloading the full thing. This all happened in the space of 10 minutes.

  • This was the easiest way. Just Option+Click Download. And it downloaded the full version, about 5.20 GB.
    – majidarif
    Nov 12, 2017 at 1:43
  • 1
    Option+Click does not work.
    – RHaguiuda
    Mar 12, 2018 at 13:03

First you need to install High Sierra and then boot it. In High Sierra, open Safari and then open this URL to download the installer again:


Only when downloading from within High Sierra I get an installer that contains the installation files, when I download it in Sierra, my installer is also just about 8 MB, the installation files are downloaded only on install (no idea where the system is storing them during installation).

BTW, if you want an installer medium, create a writable DMG with Disk Utility (6 GB of space is sufficient, make sure File System is MacOS Extended, not AFP, leave all other values default), quit Disk Utility (otherwise it will prevent certain kind of write access to that new volume), open Terminal app to get a terminal window and then run:

sudo "/Applications/Install macOS 10.13 Beta.app/Contents/Resources/createinstallmedia"  --applicationpath "/Applications/Install macOS 10.13\ Beta.app" --volume "/Volumes/Untitled"

when prompted, enter your admin password. Here is the command again, just broken down for readability:

INSTALLER="/Applications/Install macOS 10.13 Beta.app"
sudo                                          \
    "$INSTALLER/Resources/createinstallmedia" \
    --applicationpath "$INSTALLER"            \
    --volume "/Volumes/Untitled"

Will take a while. Finally open Disk Utility again, select Images > Convert..., pick your disk image, choose a name and select Image Format to be CD/DVD Master. After the convert you have a disk image you can burn to get a real installer DVD that is also bootable.

  • 1
    Thanks for the comprehensive answer! That's quite interesting and differs from past developer previews :)
    – Panda
    Jun 6, 2017 at 12:51
  • Apparently, it's something to do with the disk space left on the Mac - MacRumors thread
    – Panda
    Jun 6, 2017 at 16:59
  • @Panda When I downloaded the installer in Sierra and just got the 8 MB installer, I had over 800 GB of free disk space. When I downloaded the installer in High Sierra I just had about 150 GB of disk space (as I just created a smaller sub partition to install High Sierra), so unless it's an issue with "too much free disk space", I somehow doubt it :-P
    – Mecki
    Jun 6, 2017 at 17:07
  • 1
    Wow, apparently it's not that either. I do see some users getting the 7.8 MB file while others got the larger one on Sierra, not sure why though. Really weird :D
    – Panda
    Jun 6, 2017 at 17:09

Download macOSDeveloperBetaAccessUtility.dmg. Then, in a VM try installing 10.13. After you agree to the Terms & Conditions let it download.

Do not click restart. You will have the Installer in your /macOS\ Install\ Data/ directory.

  • I always get the 8MB installer but this alternative worked for me
    – Perry
    Sep 14, 2017 at 21:10

For others looking for this, it looks like the InstallESD.dmg-file ends up in /macOS Install Data/ when you start the actual install. So just let it finish downloading, copy the file and then cancel the install process.


I had a similar problem installing the final release of High Sierra. I had macOS Sierra 10.12 and when I downloaded the install from App Store always It's only 19.9 MB.

  • First remove the corrupted file from Applications/
  • I clean my caché with CleanMyMac.
  • I restart my Mac.
  • I open App Store and search for update and install a update's macOS Sierra with version 10.12.6.
  • Finally and after the restarts of the update I open App Store and downloaded High Sierra without problems.

Your downloaded file seems to be corrupted or downloaded incompletely. So, download it again see what'll happen, with opening this in Safari: enter image description here macappstores://itunes.apple.com/app/id1209167288

I downloaded it and it's 5.26 GB, although it downloaded about 4.9 GB as App Store mentions (I think download file is compressed).

Again, I mention you that a few times I stopped the downloading with removing the installation app from launchpad and again I resume the downloading without any problems and it continues with the size that downloaded before.

  • Thanks for your answer! I've downloaded a few times but it still seems to be 7.8 MB. I'll think I'll restart my computer and try again later.
    – Panda
    Jun 6, 2017 at 7:52
  • Sorry, but what you say is just not true. The installer app itself is in fact just 7.8 MB. No idea what you downloaded, but I can reproduce that on several systems with several different accounts. Only when running the installer (which I did, installed just fine!), the rest of the system is downloaded, I just don't know where. Please add an image to your reply showing how that installer app is 5.26 GB on your system. I'm sorry, but in your case I have to say "pic or it didn't happen". Oh, and please, a pic from 10.12!
    – Mecki
    Jun 6, 2017 at 11:20
  • @Mecki Actually, I did come across the 5.26 GB file in some YouTube videos, so I think it does exist. Just that I'm not sure why my Macs aren't getting it. Just curious, are all your systems running the latest version of Sierra?
    – Panda
    Jun 6, 2017 at 12:48
  • @Panda Yes, it does, see my reply. It exists when you download the installer within High Sierra, but I've not seen anyone getting it when downloading the installer in Sierra (and a lot of people I know have tried it already)
    – Mecki
    Jun 6, 2017 at 12:50
  • @Panda Okay, I took screenshot and upload it. Take a loot at it. I don't know why your download files are different.
    – Mahdir
    Jun 6, 2017 at 16:42

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .