1

This is a 3 TB external Seagate hard drive formatted in Mac's Disk Utility as a single non bootable exFAT partition. It got unplugged from the computer and now the computer is unable to read it.

sudo gpt -r -vv show /dev/disk4:

gpt show: disk4: mediasize=3000592977920; sectorsize=4096; blocks=732566645
gpt show: disk4: PMBR at sector 0
gpt show: disk4: Pri GPT at sector 1
gpt show: disk4: Sec GPT at sector 732566644
    start       size  index  contents
        0          1         PMBR
        1          1         Pri GPT header
        2          4         Pri GPT table
        6      76800      1  GPT part - C12A7328-F81F-11D2-BA4B-00A0C93EC93B
    76806        250
    77056  732489472      2  GPT part - EBD0A0A2-B9E5-4433-87C0-68B6B72699C7
732566528        112
732566640          4         Sec GPT table
732566644          1         Sec GPT header

Is it possible to recover the hard drive?

Update: I had to unplug and plug the external hard drive back in. It takes about 5 mins for computer to recognize the hard drive. The following screen pops up. enter image description here

I ran the first aid from the disk utility app and the operation was successful but it still show the disk as uninitialized.

diskutil list:

/dev/disk4 (external, physical):
#:                       TYPE NAME                    SIZE       IDENTIFIER
0:                GUID_partition_scheme               *3.0 TB     disk4
1:                        EFI EFI                      314.6 MB   disk4s1
2:       Microsoft Basic Data SEA_EXFAT                3.0 TB     disk4s2

The hard drive doesn't show up in finder.

diskutil verifyVolume disk4s2:

Started file system verification on disk4s2 SEA_EXFAT
Verifying file system
File system check exit code is 1
Error: -69845: File system verify or repair failed
Underlying error: 1: Operation not permitted
  • @klanomath is the format correct? I'm new to this. – giggabig Jun 5 '17 at 19:22
  • Ok, I think I just messed it up. Do you think I can recover the hard drive? – giggabig Jun 5 '17 at 19:30
  • I'm unable to run verifyVolume. – giggabig Jun 6 '17 at 1:41
  • I've updated the command output. I don't know why the list command doesn't show the two partitions. – giggabig Jun 6 '17 at 19:09
  • @klanomath I finally was able to perform the diskutil verifyVolume disk4s2 command. – giggabig Jun 9 '17 at 0:28
2

I think the drive is already unmounted, if not then unmount it and do this

try mounting in read only mode by doing this

diskutil mountDisk readOnly /dev/disk2s1 

Check if the drive is hijacked by the system

ps aux | grep fsck

If you see your disk there hijacked then use this to kill this process

sudo pkill -f fsck

You should immediately see your drive at the finder's sidebar.

  • What does it look like for the drive to be "hijacked by the system"? Is it /System/Library/Filesystems/exfat.fs/Contents/Resources/./fsck_exfat -y /dev/rdisk2s1? – Merchako Mar 9 at 3:56
1

I had the same issue before with my 4TB Seagate external hard drive too. It also takes too long for the system to recognize my disk, and a lot more issues came with it.

If you unplugged your drive without unmounting / ejecting it properly, it could potentially been occupied by some processes such as quicklookd in the background, this can potentially cause problems like corruption in the file system or corruption in clusters. But, if you were not making any modifications to your data at the time when you “unexpectedly” unplugged your drive, the data may not be affected, it’s just the file system is unrecognizable for your Mac temporarily since it could be broken when you unplugged your drive.

Here’s the trick, it worked like a charm to me every time when I unexpectedly unplugged my drive without properly ejecting it:

diskutil list # to see the identifier of your drive
# disk2s1 will be used in this example, replace it with your own drive identifier
sudo fsck_exfat -y disk2s1

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .