1

I'm trying to Homebrew my Nintendo Wii, and a 2 GB or under SD card is required. However, the Wii will also recognize 4 GB cards if enough junk is put on it. I'm attempting to do this with my Optima 4GB SD Card (goo.gl/qqJn8p) on Mac OS X, El Capitan (v. 10.11.6). After formatting it to ExFAT, I put a 1.28 GB file on the card. Everything went smoothly. The next time I tried, though, I got an error saying that there wasn't enough space, even though there's plenty left. Here's a screenshot of the SD card info.

I know that this is a common problem with USB's, but is there any solution for SD cards?

*As a sidenote, I formatted with Disk Utility.

(ex-post from Stack Overflow)

  • What's the partition scheme? If it's GUID, try changing it to MBR. – NoahL Jun 4 '17 at 6:26
  • The fact that the total capacity shows as being less than the remaining space rings alarm bells. I'd try 2 things; first format it with the official formatter from the SDorg -sdcard.org/downloads/formatter_4/index.html - then test with Fight Flash Fraud app F3X to make sure it's the size it claims to be. – Tetsujin Jun 4 '17 at 7:10
  • I've done this before. The Wii doesn't need exFAT. I just used FAT32 or (FAT) with a MBR. Try copying the files again, and it should be fine. – bret7600 Jun 4 '17 at 14:37
  • 1
    Just formatted to FAT32 with SDFormatter and checked the card's status with F3X and everything seems to be okay. There's no longer the negative gigabytes in Disk Utility. I noticed that although there are nearly 3 GBs worth of files in the card, it says that there are 2.71 GBs left. After trying to put an 80mb file in it, I got the same error message saying that there wasn't enough space. Image for reference: i.imgur.com/prA4ePc.png – Brendan B Jun 4 '17 at 23:55

You must log in to answer this question.

Browse other questions tagged .