2

My MacBook Pro battery is not charging for days. It only stops at 8% (not increase or decrease) when I plug in.

enter image description here

In addition, the light at the end of charger does not turn on.

enter image description here

What is the problem of it? How to fix it?

The detail of my MacBook Pro is as follows: enter image description here

  • What is your MacBook Pro version? Update your question with more details in order for other people to help you. – N. Cornet Jun 3 '17 at 12:37
  • Have you tried a different charger? Have you tried an SMC Reset? – Allan Jun 3 '17 at 12:47
  • I haven't. I will try this and tell you the result. Thank you! – wayne Jun 3 '17 at 12:49
  • Once you have determined that your charger works (you can try your charger on a different Mac, too) see this answer – Allan Jun 3 '17 at 13:17
  • Does the light charging indicator turns on when charging from 0% to 8% ? – N. Cornet Jun 3 '17 at 13:40
4

The lack of a charging indicator light is not a good sign, as it implies a hardware problem of some sort (i.e. cable, charger and/or MBP).

However, one thing you could do is reset the System Management Controller (SMC) to see if that resolves the issue.

  1. Shut down your Mac
  2. Unplug the power cable from your Mac
  3. For 10 seconds, press and hold at the same time the shiftcontroloption keys (on the left side of the built-in keyboard) and the power button
  4. After 10 seconds let go of all keys and the power button
  5. Plug in the power cable
  6. Turn your Mac back on with the power button.

If the problem still persists after doing this, an easy test to do is to see what happens if you use another charger/cable. If the problem still persists with another charger/cable, then you really should run Apple Diagnostics (you can also run diagnostics in the meantime if you haven't got access to another charger/cable).

Run Apple Diagnostics

Follow the steps below to run Apple Diagnostics:

  1. Fully shut down your Mac
  2. Restart your Mac
  3. Immediately press the D key and keep it down until you see the Diagnostics screen appear
  4. Wait for Diagnostics to finish (this typically only takes a few minutes)
  5. Once complete, one of two things will appear on the screen:
    • a No issues found message
    • a brief description of any errors found plus further instructions
  6. If the diagnostics test does find errors, take a note of what they are

Note: If pressing and holding the D key at Step 3 doesn't work, start again at Step 1 and, at Step 3 press and hold both the OptionD keys instead. This will try and run diagnostics from the internet instead, so you will need to allow more time for it to complete.

Regardless, take a note of what happens and let me know how you went.

  • Thanks for your great answer. I had tired your solutions, the following are results: 1) Rest SME, failed at step 3. After pressing 'shift-control-option' & 'power button' simultaneously, there is no response (dark screen); 2) Run Apple Diagnostics. At step 3, it said '! Connect the power adapter to run Apple Diagnostics', but my adapter are connected. 3) Haven't tried another charger, since it's too late in our region. – wayne Jun 3 '17 at 13:42
  • It is quite strange. After I unplugged the power cable from your Mac for about 20 mins, then I plugged in again. It works back to normal. And the light turns on. Don't know why? Very baffling. – wayne Jun 3 '17 at 14:04
  • 1
    Resetting the SMC may have resolved it. The no response dark screen you refer to isn't a problem as your Mac was switched off. You'll have to monitor it for a day or so to see if the issue is resolved or not. Good luck! – Monomeeth Jun 3 '17 at 14:21
1

I have been struggling with the same issue for a month. I tried everything to solve the problem including SMC reset, removing battery and etc. Finally, ten minutes ago, I sprayed both the charging connector and charging port with electrical contact cleaner spray and the problem was solved! Before try it be sure you turned off your MacBook Pro.

  • Unfortunately the problem has arisen again. – oguznamal Jul 2 at 14:11
  • I wish I could see your answer 2 years ago – wayne Jul 3 at 0:34
0

This appears to be a common issue with this kind of machine. Louis Rossmann describes how to address a motherboard repair on his videos like https://www.youtube.com/watch?v=5HUyEykicEQ .

  • While this link may answer the question, it is better to include the essential parts of the answer here and provide the link for reference. Link-only answers can become invalid if the linked page changes. – grg Oct 31 '18 at 18:01
  • Thanks for your answer. Maybe it is not about the motherboard issues. After I changed another charger, it works again. – wayne Nov 1 '18 at 3:15
0

my laptop had this same problem of not charging. I visited this page and followed the instructions to reset the SMC but that failed and ofcourse diagnostic is practically useless since it keeps asking you to "Connect the power adapter" which won't work because that's the problem in the first place.

I had to replace my charging port. That fixed my laptop. Hopefully this saves someone time and worring. It cost me N15,000 ($41.32).

0

Could the charging port and/or charging connector be obscured by dust and debris? Maybe a dash of compressed air might clear it out enough to make a successful contact? Do not use any liquids to try and clean there.

Happened to me once...

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .