1

As of today, when I connect iPhone to Mac to sync something weird happens. The phone seems to think it needs to copy all 10,000 tracks. It does so, takes 90 mins. Finishes with no error messages. And when I disconnect from the Mac, iPhone says it has no songs/music stored on the phone.

I have made any changes in recent days. What is going on?

I'm on an iPhone 7 with iOS 10.3.2. Also latest iTunes - 12.6.1. There is 91GB of space left on the 127GB phone.

  • Do you remember if it worked before, but after you upgraded iTunes to 12.6.1? I ask because I can't currently sync music at all, and I wonder if some bug was introduced with 12.6.1. – Harald Hanche-Olsen Jun 3 '17 at 8:56
  • Regarding the problems I was seeing: After rebooting the phone (which did not help on its own), then quitting and restarting iTunes, I can now sync music again. This may well be unrelated to the problem you are seeing. But if you haven't done so already, the same steps might well be helpful. iTunes seems like such a big ball of mud, things frequently go wrong with it. – Harald Hanche-Olsen Jun 3 '17 at 11:57
  • Delayed in getting response to you as I've been offgrid. I had NO problems before recent iTunes upgrade. Never experienced this problem. I've tried the hard boot on the phone, and the laptop but will try again. Desperate times call for repeating one's actions! Thanks for the comments. – Catmindu Jun 6 '17 at 16:27

You must log in to answer this question.

Browse other questions tagged .