4

I just downloaded Office 365 for Mac, and tried to install it in macOS Sierra 10.12.5. The installation froze when Running Package Scripts.

It is a common problem. I followed this answer and launched Disk Utility, but it seems that there is no repair disk permission in Sierra.

Then, I found the answer of dianeoforegon here. I did pay attention to close all browsers and applications (except Finder) before launching the installer. Clicking on Shift did not help either.

It is really annoying. Does anyone have a solution? Otherwise, how could I clean what I have installed completely?

Edit 1: I chatted to Microsoft support yesterday, and they let me create a new user account on my Mac, and install Office 365 under that account. I tried, the installation was freezing at the same place.

Edit 2: I chatted to another Microsoft support agent, he suggested me to remove the Office before installing, I then removed them in Applications, there was no Library/Containers or Library/Group Containers (I guess it is because the installation was not completed). And the re-installation still failed at the same place.

Additionally, I have to use VPN to connect to the internet, some sites still don't work well. Is this an issue? Does Running Package Scripts require some special Internet connection?

  • Is this a totally fresh installation (i.e. no prior installation of Office 365)? If so, as far as you can tell, has anything been installed at all? – Monomeeth Jun 2 '17 at 0:45
  • There was for example Microsoft Excel previously installed, and I don't remember other applications. I don't know how to check if anything new has been installed. If I look at the Date Modified in Applications, I don't see any Microsoft xxxxx whose Date Modified is yesterday. – SoftTimur Jun 2 '17 at 6:50
1

The first thing I would try is booting into Safe Mode and installing Office 365 from there. This is what I think the answer of dianoforegon you referred to was trying to achieve, but her steps weren't the best way to go. Instead, try the following:

  1. Fully shut down your Mac
  2. Restart your Mac
  3. Immediately press the Shift key and keep it down
  4. Let go of the Shift key when you see the login window (NOTE: If you have FileVault enabled you may need to log in twice. Also, booting into Safe Mode can take quite a while in some cases.)
  5. Now try installing Office 365 again from your download
  6. If it doesn't work, take a note of any errors etc you get
  7. Exit Safe Mode by restarting your Mac as normal

Let me know if this doesn't work and any error you get.

  • Thank you... The booting into Safe Mode took 10 minutes, then I could finally launch the installer. The installation was freezing at the same place (running package scripts)... – SoftTimur Jun 2 '17 at 6:46
0

Turn off virus protection. As soon as I did that the installer completed the task.

  • wow super, disabling virus protection worked! – Kirak Apr 30 at 23:36
0

This worked for me: Go to Acitivity Monitor and quit "installer". This prompts the last bit of installation.

https://discussions.apple.com/message/32522381#message32522381

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .