1

I'm using Mavericks,10.9.5.

The time on the menu bar exactly matches the time in the official Date and Time area… It is that time in the official area that is incorrect.

First the time was about 30-40 seconds fast, and then I had to restart the computer several times because of an unrelated issue, and now I'm nearly a minute SLOW. Using a comment that I found in another thread, I found the terminal (for the first time ever!), entered this:

sudo ntpdate -u time.apple.com

And the result was this:

31 May 15:29:14 ntpdate[2476]: step time server 17.253.26.253 offset 50.650629 sec

What is the next step in trying to fix this issue... preferably in words of one syllable?

1

The use of ntpdate is considered deprecated. Most would recommend using ntpd instead, which is what the underlying system uses.

First, check in the "Date & Time" System Preferences pane that you have "Set date and time automatically" checked and have selected a time server. then try sudo ntpd -g in the terminal.

If this doesn't work then I would suspect a firewall issue on your network. You don't say if this is happening at work or home or regardless of location.

  • Set date and time automatically" is checked. "sudo ntpd -g" just gave me a blank line in response. I substituted ntpdate, and it gave me the following: ntpdate: unknown option -g usage: ntpdate [-46bBdqsuv] [-a key#] [-e delay] [-k file] [-p samples] [-o version#] [-t timeo] server ... – Going crazy Jun 1 '17 at 0:39
  • Does anyone have any thoughts about this? – Going crazy Jun 4 '17 at 7:03
  • @Goingcrazy - sudo ntpd -g only allows ntp to set the time by making "big jumps" - 1 min off will have no effect. What does your syslog say? cat /var/log/system | grep -i ntp Also, post the output of cat /etc/ntp.conf – Allan Jun 4 '17 at 23:58
  • I have no idea what a syslog is, sorry. cat /var/log/system | grep -i ntp cat: /var/log/system: No such file or directory cat /etc/ntp.conf server (time.apple.com) – Going crazy Jun 5 '17 at 3:39
  • So… What does that mean? :-) – Going crazy Jun 7 '17 at 23:18
0

I switched to time.nist.gov, and that seems to have fixed it.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .