1

I have what appears to be a corrupt system font (.Geeza Pro PUA). How do I go about replacing it with a working version? iMac running 10.12.5.

It's doing this:

enter image description here

  • 1
    Geeza Pro is only for Arabic. Do you really need it to be "working"? Are you having problems with work you do in English or other languages? – Tom Gewecke May 31 '17 at 21:17
  • Tom, we don't do any Arabic, so the problem appears exclusively in English. I'm guessing that the corrupt font is having a ripple effect because the machine that's doing this is displaying garbage in Mail and other system apps. Our other Macs are alright, but the font on this one is a) not activated; and b) listed as unavailable when I list the system fonts through Universal Tye Client. I've tried resetting/restoring the system fonts both through Font Book and "fontrestore default" from Terminal. Thanx. – Kent Hamele May 31 '17 at 21:53
  • Would you add a screen shot of this garbage? That is your real problem, and it may have other causes. – Tom Gewecke May 31 '17 at 23:21
  • Tom-- I just added a screen grab of a representative email. – Kent Hamele Jun 1 '17 at 15:10
  • Thanks Kent! That problem is normally solved by the Restore Standard Fonts action. You must have something unusual. There's a fellow you might ask who is a font expert, his site is jklstudios.com/misc/osxfonts.html – Tom Gewecke Jun 1 '17 at 15:55
1

Open Font Book.app and choose File → Restore Standard Fonts….

  • I did that. The file for .Geeza Pro PUA, even though there's something wrong with it, does not get swapped out for a good copy. We use Universal Type Server and the attendant client, and the font on the machine in question is not activated, and is listed as "unavailable" in the preview window. – Kent Hamele May 31 '17 at 21:25
0

You could probably swap a working version on the other macs to replace this corrupt one but the font name does suggest that the font uses Private Usage Area for specific characters, my knowledge even unicode doesn't have a standard of what should be encoded to that set. Don't use this font, buy or licence a font that works well. For a relatively well supported font I'd suggest Noto from Google

  • There might be something wrong with this particular font on the posters system, but OS X has lots of similar "PUA" things and normally they do not cause any problem for anyone. See support.moonpoint.com/os/os-x/fontslist – Tom Gewecke Jun 1 '17 at 19:59
  • Yeah you're right on that front, doesn't mean that pua is a legitimate way to get accurate representation across many systems, in fact it will ensure OP keeps getting these kinds of errors because that character set has no specific standard. – Sewesakehout Jun 1 '17 at 20:08
  • Even if such fonts have a PUA component for some legacy reason, OS X never uses the PUA for representing text in its apps, it only uses standard unicode. Nobody actually has any problems exchanging data across platforms via these fonts. – Tom Gewecke Jun 2 '17 at 13:22
  • @TomGewecke you are indeed correct. My comment stemmed from the fact that PUA was listed in the font name, probably bad to assume that that specific font was calling on that set to display Latin characters, but my experience has yet to prove this assumption wrong. – Sewesakehout Jun 2 '17 at 15:12
  • It's true, Geeza Pro, even without any defects, has no Latin characters, only Arabic. So if for some reason an app is trying to use it for Latin text instead the dozens of Latin fonts, then you will see question marks. – Tom Gewecke Jun 2 '17 at 15:23

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .