I have an MP3 file located on my iPhone that I want to delete but am unable to find in the Music app.

The track only appears when I connect my iPhone to my Mac and go to (Devices > iPhone > Music) in iTunes. There, it shows a list of all of my voice memos and songs in my music library. I have already deleted all of the songs from my music library using (Settings > General > Usage > Music...) on my iPhone, but it did not delete the file in question. I know absolutely for certain that it is not a voice memo.

There is now a circle with an exclamation mark next to the file in iTunes, but secondary clicking on it does not offer a remove or delete option. Does anyone have any suggestions on removing the file?

4 Answers 4


Do you or have you ever used iTunes to sync the phone? If so, try another sync.

  • Yes, I have synced repeatedly.
    – Jared
    Jun 4, 2017 at 22:54

Have you tried to reset iTunes cache?

iTunes -> Peferences -> Advanced

As an option go to About this mac -> Storage click Manage… and then select iTunes. Perhaps those file will be there.

  • Yes. Sorry, but no dice.
    – Jared
    Jun 7, 2017 at 20:25

If you've already tried the other answers, back up your iPhone & then restore it in iTunes - this will almost certainly fix this issue.

  • Performing a full backup to the computer then restoring the iPhone to the backup did not solve the issue.
    – Jared
    Jun 7, 2017 at 20:34
  • Hmm. Is the file taking up space on the iPhone? It doesn't seem like it's actually there, which is an issue with iTunes if so Jun 7, 2017 at 22:10

I managed to successfully remove the listing by downloading the iOS file explorer iFunbox and poking around inside of the iPhone's raw filesystem.

The process I took was rather unscientific, but after deleting many of the files and directories located in directories such as Downloads, MediaAnalysis, and Music and iTunes-related folders, the bad listing disappeared.

My suspicion is that the file was appearing because of a bad SQL entry, and that deleting all of the .sqlite files fixed the problem.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .