1

I'm trying to mount a drive from Linux on my macOS El Capitan laptop. I try a command like this:

sudo mount -o rw -t nfs nfs.subdomain.employer.com:/ifs/home/username /private/workspace/
cd /private/workspace/
echo "hello" > test.txt
-bash: test.txt: Permission denied

where username (the text, not the uid) is the same on my laptop as it is on the server (controlled by my employer). Unfortunately, while I can read files, I'm not getting write access. A colleague of mine said he tried that command from linux as my account and said it worked, but he doesn't know much about macs.

  • You have to set the permissions on the remote computer you have configured the nfs share on. You need to edit the entry in the /etc/exports that pertains to your particular share. – Allan May 31 '17 at 20:40
  • Possible duplicate of How to share directory over NFS from Mac? (w/o macOS Server app) – Allan May 31 '17 at 20:42
  • It looks like that link describes how to mount on Linux from macOS. I want the reverse. Also, as I understand it, my colleague was able to mount the drive on a Linux workstation, so the server is already set up. Does getting write access from macOS require different server settings or am I misunderstanding something? – amos Jun 1 '17 at 13:02
  • The last time I set up NFS sharing with macOS was a few years ago and from what I remember, there was some settings on the server that I had to configure for rw access. Ever since I switched to SMB2, I don't have any of those issues anymore. – Allan Jun 1 '17 at 13:07
2

I have this setup, please do the machine/folder names translation according to your case. In /etc/exports on server side (mine is a centos 7):

/workspace_guest/02.code 
172.20.0.1(rw,sync,insecure,all_squash,anonuid=1000,anongid=1000)

From client side (macOS Catalina Version 10.15.6)

$ sudo mount -t nfs -o resvport,rw,noowners 172.20.0.100:/workspace_guest/02.code /Volumes/C76/02.code

There is a good explanation in this post as "all_squash will map all UIDs and GIDs to the anonymous user, and anonuid and anongid set the UID and GID of the anonymous user.". I make it on the client side as "noowner" is to apply the current user/group as the "anonymous". You can also refer to the other post for the configuration.

| improve this answer | |
  • Just used this solution today to mount Ubuntu 20.04 on MacOS Catalina and it worked perfectly. – Mike Fischer Jul 16 at 21:45

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .