After formatting the HDD to a single HFS+ Journaled partition and installing a clean 10.7 System on the machine, I ran the Boot Camp Assistant, created the CD with drivers and partitioned the disk. I then put the Windows7 DVD+R in the machine which I had created on another Windows machine by using the Microsoft USB/DVD/Download Tool to burn our site license image to a disc.

After partitioning, the machine restarts, but just shows the text "No bootable device -- Insert boot disk". Then, nothing more happens. When I shut the machine down and reboot it while holding option down, I see that the DVD appears twice in the list of bootable devices - once as "Windows" and once as "EFI Boot". Both do lead to the same error if selected for booting. The installation disk itself works perfectly in "normal PC". I nevertheless burned another one, it doesn't work either. I then used the Microsoft Tool to create a bootable USB stick. But this neither shows up in the Startup Disk preference nor when holding option during startup.

I had an older Windows XP disc lying around which I then tried on this machine. It installed without flaw. However, the Lion Boot Camp drivers do not support XP anymore and anyway I need to install Win 7 on the machine.

This all leaves me to these conclusions: Boot Camp Assistant worked and has created a usable partition (see XP install). The installation discs for Win 7 are also correctly set up (they boot on a PC) and work. Booting Windows 7 from a USB device apparently is unsupported on my machine.

Which leaves me clueless. All parts on their own seem to work. Any idea why they don't work together?

2 Answers 2


In the end, I couldn't make the machine boot from the DVD. However, I found a workaround that I want to share for anyone with a similar problem: I used VMware Fusion to boot the Boot Camp partition from OS X. I then set up the VM to boot from the iso I made the DVD from (might have worked with the DVD as well, didn't try). After running through the part of the installation where the base system was written to disk and the system wanted to restart, I turned off the VM, booted from the Boot Camp partition and (with Win7 DVD in drive) then ran through the rest of the installation procedure without problem.

  • What does "I used VMware Fusion to boot the Boot Camp partition from OS X" mean?
    – Calaf
    Commented Mar 29, 2012 at 4:51
  • Also, VMware uses its own "filesystem", a collection of 2GB files. How did you force it to use Windows' native files? (Or were you using other than VMware Fusion 4?)
    – Calaf
    Commented Mar 29, 2012 at 4:53
  • VMware can boot a BootCamp partition, see "Power On the Boot Camp Partition as a Virtual Machine" in the VMware help. I used VMware Fusion 3.
    – mss
    Commented Mar 30, 2012 at 7:10

Hard to say exactly, but here's what I would try next based on the EFI Boot partition showing up in the boot selector:

Reset the PRAM by holding Apple-Option-P-R at the chime, and allow it to chime two or three times before releasing those keys. Then try booting from the Windows CD again.

  • No, sorry, that does not help. To be fair, at least the MBP now seems to decide quicker that it wants to boot from one of the installed systems :) I held it down for three chimes.
    – mss
    Commented Oct 26, 2011 at 8:35

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .