35

Periodically, Spotlight stops responding to keyboard input on my Mac. When this happens, pressing cmd-space brings up the Spotlight search field, but typing search terms has no effect. Characters don't appear in the search field, and even pressing ESC doesn't exit from Spotlight. The keyboard continues to work normally in every other app-- only Spotlight is affected.

Rebooting restores normal operation but I'm hoping there's some non-reboot way to get things working again.

I'm running macOS 10.12.5 (16F73) on a 15" touch bar MacBook Pro. Both the internal keyboard and an external Apple USB keyboard are affected.

  • Have you tried rebuilding the Spotlight index? I've seen that it can fix some Spotlight issues, but I don't know about that one. – N. Cornet May 30 '17 at 16:51
  • No, because the problem isn't that Spotlight can't find results, it's that it's impossible to type search terms.in the first place. I'll try it in the spirit of covering all bases though. – Tom Harrington May 30 '17 at 17:03
  • FWIW, that made no difference. – Tom Harrington May 30 '17 at 18:12
  • When I had this problem, command-line searching via mdfind MySearchQuery works perfectly, so it's not a spotlight index problem. – Demis Apr 5 '18 at 4:12
55

This seems to have worked. I'd still be interested in other answers people might have, in case there's something better.

  1. Run Activity Monitor
  2. Type "spotlight" in the search field.
  3. Several items will be remain. Select the one just named "Spotlight". Use the "x" button at the upper left corner of the window to kill it.

Spotlight automatically re-launches, and now works.

  • 7
    Help, I only launch activity monitor from spotlight (I know it's funny, but I'm not kidding) ...k, it's under Applications --> Utilities, future person who has this problem – red Mar 3 '18 at 4:12
14

A more faster way than the GUI is through Terminal:

  1. Run Terminal (via Application panel -> Other -> Terminal)
  2. Type: killall Spotlight

Spotlight will restart and be operational.

  • That should work but I don't see that it's any faster. – Tom Harrington Oct 18 '17 at 14:42
  • 2
    Using killall Spotlight from Terminal will directly kill the Spotlight app while with Activity Monitor you need to 1) search on the result list and 2) click on the close button. – Aurélien Bourdon Oct 19 '17 at 11:51
  • Eh, in both cases you launch an app and then type something. With Activity Monitor you point and click to take action, with Terminal you type a little more. Unless you're doing this constantly, any time difference either way is meaningless. – Tom Harrington Oct 19 '17 at 14:52
  • 1
    Right but a lot of people will have terminal open anyway.... – Peter Feb 5 '18 at 17:04
  • Handbags at dawn. – Mr Chris Oct 8 '18 at 15:25
1

h/t to https://all-about-apple.com/unable-type-spotlight-search-bar

Bring up spotlight via the system menu, press backspace. You might need to do this twice. No idea why this works...

1

If the above mentioned are not working then give a try for this:

  1. Open Terminal
  2. Type - not copy! - the following but wait a few second between them:

    sudo mdutil -i off /
    sudo mdutil -i on /
    sudo mdutil -E /
    

If, after a few minutes, Spotlight is still not indexing, try running this command, followed by the three commands above:

sudo rm -rf /.Spotlight-V100

This is the site where the help comes from, big thanks for it!:

https://www.amsys.co.uk/blog/how-to-fix-spotlight-search-on-a-mac/

  • That page doesn't sound like it's addressing the same problem. It wasn't a question of not getting good results on a search, it was that it was impossible to even type a search term in the first place. – Tom Harrington Aug 13 '18 at 16:25
0

Sometimes, the simplest and most obvious solution works. In Systems Preferences, open Spotlight and select the Search Results panel. Uncheck everything, then quit Systems Preferences. Reopen, then check all the items you wish to enable. That's it. BTW: As a privacy tip, by not checking the stand alone box for allowing Spotlight suggestions, you disable search results from automatically being sent to Apple.

  • Did that work with the problem described above? I haven't had this problem in a long time so I can't verify, but that doesn't seem like it would work. The key seemed to be making Spotlight quit and relaunch, but these steps don't do that. – Tom Harrington Sep 25 '18 at 17:18

You must log in to answer this question.

protected by Community Oct 2 '18 at 16:59

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .