2

Having some trouble restoring a Time Machine backup. After some initial disk problems we had to reinstall OSX and this is what has been done thus far:

  1. Booted into Internet Recovery Mode (Command (⌘) – Option (⌥) – R)
  2. Reinstalled OSX
  3. Rebooted and into Recovery Mode (Option (⌥) – R)
  4. Selected to Restore from the Time Machine Backup
  5. Restore goes fine for 6+ hours (91%) and then fails with the message, "An error occurred while restoring from the backup. Restart your computer, and then try again"
  6. I tried an older backup from the same sparse bundle but having the same problem.

I have tried this three times but it fails in the same location each time. Any suggestions at this point would be Welcome.

  • Can you clarify a few things: (1) What do you mean by some initial disk problems? (2) What version of macOS are you running? (3) What exact model of Mac are you using? (4) Have you tested your Mac's internal drive with Disk Utility etc? (5) Have you tested the TM backup drive with Disk Utility etc? (6) When you tried the older backup, was that on the same HD as the other backup? (7) And finally, how much older was the older backup you tried? – Monomeeth May 28 '17 at 10:52
  • 1. Some file corruptions. Mac would not fully boot. Reinstalled the OS and checked the drive and it came back fine according to diskutil. 2. Latest Mavericks. 3. MacBook Pro - Model A1502. 4. Yes. Came back clean. 5. No. This I have not done. Was googling this process as I saw you asked for it. 6. Yes. Same drive. 7. 2 days. – Petter May 28 '17 at 16:12
  • I just had the same experience on High Sierra. I have to say that Apple did a really shitty job with giving a false sense of security. What is the point of Time Machine if it is not near 100% fail safe (I do understand that this is impossible to achieve but I've had issues here and there with Time Machine from the get go. Never this severe though). Also supplying absolutely zero information about what has gone wrong is so typical Apple. They should know that there are advanced users out there. – sebrock Feb 27 '18 at 10:21
3

Basically you have to explore what's going wrong and fix it manually.

Hope this helps:

Inspect the installer 'Log' and if you have a 'Critical failure' pertaining to a particular folder(s), proceed with these steps:

  • Connect your backup to a working Mac (or fresh install MacOS on the back you're trying to restore to)

  • Open Terminal and mount the Time Capsule's sparse bundle (if using a Capsule rather than a plug-in drive).

  • In Terminal, use TMSafetyNet.kext to remove the troublesome folders one by one.

  • Return to Recovery Mode on the target machine and restore with the fixed backup.

Source: my blog

  • 3
    This answer would be more useful if it included the actual commands/applications required to perform the various steps. – nohillside Mar 28 '18 at 13:22
  • Welcome to Ask Different! Please note that whenever you link to your own website, you must explicitly state so. See the Help Center. – Glorfindel Mar 28 '18 at 13:22
  • On High Sierra the path of the bypass tool is different: /System/Library/Extensions/TMSafetyNet.kext/Contents/Helpers/bypass – pi3 Aug 10 '18 at 19:05
  • This was amazing I was bit worried about the Logger, but you can access it even if you have already said pick a different Backup. Then look towards the bottom and you will see the 500 error. The logger is available at the top bar. The blog post was helpful. Thank you! – Zargold Oct 28 '18 at 1:31
  • 1
    TMSafetyNet.kext fail with message "failed: Permission denied" with me, So I just use Time Machine app to open the Backups.backupdb and delete the file, and it work – Qiz Feb 23 at 13:57
0

Have you tried the Migration Assistant instead of using Time Machine to restore from the Time Machine archive?

My 2012 Airbook recently crashed. It took several passes at reformatting the drive to get it functional. I ended up losing my Boot Camp partition. Once It originally had Mt. Lion installed, but once I got access to the High Sierra internet recovery tools I was able to reclaim all my hard drive storage space, install the OS and boot into it. From there I used Migration Assistant to restore my computer.

These tools and techniques may help you:

  1. Resetting the NVRAM:
    • hold down +option+p+r while booting/restarting...
    • let the mac chime 3-4 times, then let go of the keys and let it reboot.
  2. Disk Utility's First Aid in Recovery Mode, or Internet Recovery Mode:
    • +r, or
    • +option+r at bootup
  3. Resetting the SMC (System Management Controller):
    • Might be as simple as:
      1. shut down,
      2. unplug power,
      3. hold SHIFT+CTRL+option+POWER for ten-fifteen seconds then
      4. boot up.
    • Check the linked article for specifics to your machine.
  4. Apple Hardware Test:
    • Restart holding down d
    • Run the basic test, and run the extended test.
    • Run them a second time. Any improvement?

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .