2

With user-created dictation commands, it's possible to paste text into an application. I tried creating a voice command that would paste in a text command into Terminal. However, nothing gets pasted. I can see the command get activated because the "Edit" flashes. I am able to paste text into other applications with voice commands without an issue.

Does anyone know of a workaround to this problem?

  • 1
    Interesting problem, I've just tried it with Sierra 10.12.4 and it works fine for me into Terminal. – grg May 26 '17 at 16:27
  • Good to know. I'm on 10.12.5. Hmm. Let me try on another Mac. – StevieD May 26 '17 at 16:29
  • Same problem on other computer with 10.12.4. – StevieD May 26 '17 at 16:33
  • Are you creating a new command with the advanced commands feature to paste in a string of pre-determined text or are you just straight dictating your text into the dictation tool? – StevieD May 26 '17 at 16:46
  • 1
    Same exact bug with iTerm, how odd. – grg May 26 '17 at 17:04
2

This problem continued for me when I updated to 10.13.3 but I found a solution. Rather than using the Paste Text option when creating the new Dictation Command, use the Paste Data command. Then go to TextEdit and type the text you want, select, and copy it. Then go back to the window creating your Dictation Command and click on the Import from Clipboard button. You will notice that the button moves down (I assume meaning that there is data there now). Now my Dictation Command works! I am not sure if this works in earlier versions of Sierra.

1

Just make sure and enhanced dictation is enabled. You do not need to create a new dictation command. Just select the text you want to copy to your clipboard and speak the command “copy that” . Then in the terminal app, just say the command “paste that”

enter image description here

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .