1

I want to download macOS Sierra from the App Store to create a bootable USB stick (according to Apples web page). However, the App Store tells me that I have installed it and only shows me an "open" button. There is no Install macOS Sierra app in the applications folder. Spotlight however finds it, but it is marked as unknown version and does not start from there. I also cannot find it in Finder. Any ideas?

  • Can you try holding down the Command key while clicking on the "Install macOS Sierra" that appears in Spotlight? (Just to see where it goes?) – Edric May 25 '17 at 7:49
  • Actually, this helped me to solve it. Spotlight (and obviously the App Store as well) found it on a USB stick that I had previously mounted but already erased. I should have followed "Have you tried turning it off and on again"... That fixed it. – DaPhil May 25 '17 at 12:50
4

I see several issues with different solutions. Let's try to fix them one at a time

Spotlight

First you should check if your Spotlight index is current. Search again for the Sierra Installation App. If it is listed, scroll down that list and click on "Show all in finder" (see Apple Support Page Description).

You get a Finder Window with all the Search results and if the Installer App is listed there you can get the Location and try to create the bootable USB Stick from there. You should also check the File Size and the Permissions of the Installer in case it is f.e. File Size 0 or you don't have permission to execute the Installer. You could also delete that Installer in order to reload it from the App Store.

If the Installer is showing in Spotlight, but is not showing up in the Finder you should rebuild your Spotlight Index (see Apple Support Page here or use a third party tool like Onyx, but be carful). Depending on your HD Size and Speed that could take some hours.

App Store

If the App store is still showing that the installer is present and won't let you download, you could try to delete (or just move it somewhere) your App Store Cache at ~/Library/Caches/com.apple.appstore. You should restart at that point and then try to Download from the App Store again.

There is a second (temporary) cache Location but only for downloads. You can get there fastest by opening the Terminal and typing in open $TMPDIR../C/. There you will find a Folder named com.apple.appstore which you could also move, restart, then try to DL again.

Try these approaches first and see if that solves your Problem.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .