7

Google Drive is installed but there is no option "View with Google Drive" or "Share with Google Drive" when I Control-click / Right-click on an item in the Finder like my coworkers have. How do you enable them?

4 Answers 4

9

You need to enable the Finder extension Google Drive.

Open the contextual menu for any file, and click on Share and then More.

That will bring you to the Extensions window.

Click on Finder and in the "Select extensions for customizing Finder" select Google Drive.

Now you should see the "View in Google Drive" and "Share with Google Drive" options when you Control-click / secondary click on files inside your Google Drive.

3
  • 2
    This used to work but no longer does now that I've upgraded the OS to Mojave. I'm bummed that I am now missing this option (used it extensively). When I look at the contextual menus options google drive is an option in all BUT the share one. Oct 28, 2018 at 22:40
  • Don't forget to restart the finder afterwards with pressing ALT + RESTART on the doc icon
    – cV2
    May 17, 2019 at 9:52
  • For me this was listed as "Backup and Sync from Google". May 22, 2019 at 9:31
3

I also find that I need to occasionally uncheck, save, then recheck the checkbox "Show file sync status icons and right-click menu". This is found in the Backup and Sync settings menu.

Backup and Sync settings

3
  • Did you manage to find out how to automate that? Or the reason why this happens? Mar 25, 2020 at 10:26
  • 1
    Neither of the solutions works for me on macOS Big Sur (M1). Feb 3, 2021 at 13:45
  • This worked for me on Big Sur, 2017 Macbook Pro. Untick, click 'OK', then go back in and tick again.
    – Danny
    May 12, 2021 at 11:40
0

everyone!

RubenLaguna's solution works actually. Despite of that I could test that on MacOS 10.13.6 (the well-know High Sierra). On High Sierra, after you get in Extensions settings, you'll not be able to find Google Drive.

A solution is simply open your Backup and Synch app, relaunch the Finder (ALT + right click on Finder then press "relaunch"). After that, you'll be able to see sharing Google Drive options after right clicking on any folder/file in Finder.

Cheers.

0

Quitting and re-launching the Google Drive app worked for me.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .