4

I rather stupidly wrote a formula that has caused Numbers to get stuck showing the message "calculating...". I've waited over an hour and it's still not completed.

I've also tried force Quitting, but the next time I open Numbers it immediately tries to carry on where it left off.

Is there a way to cancel the calculations?

4
  • Do you have a Time Machine backup? If so it may be possible to go back to an earlier version before the formula was entered.
    – bjbk
    Jun 7 '17 at 2:09
  • Does that restore my entire machine? I don't want to lose any of my other work.
    – Urbycoz
    Jun 7 '17 at 8:25
  • No, you can get an individual file from it.
    – bjbk
    Jun 7 '17 at 12:14
  • Numbers does this for me on every calculation I make. I open a new empty spreadsheet and paste in the example calculation from the documentation =SEARCH(“ra”,“abracadabra”, 5) and it does the "Calculating" sit and spin...
    – Cerniuk
    Oct 12 '17 at 19:21
2

If you have a Time Machine backup, you can get the file from an earlier state.

Icon time machine

From Apple Support:

Restore from a Time Machine backup

Restore specific files:

  1. Choose Enter Time Machine from the Time Machine menu Time Machine icon, or click Time Machine in the Dock.

Time Machine Backup specific file restore

  1. Find the files to restore:
    • Use the timeline on the edge of the screen to see the files in your Time Machine backup as they were at that date and time. The timeline may also include local snapshots.
    • Use the onscreen up and down arrows to jump to the last time the contents of the window changed. You can also use the search field in a window to find a file, then move through time while focused on changes to that file.
    • Select a file and press Space Bar to preview the file and make sure it's the one you want.
  2. Click Restore to restore the selected file, or Control-click the file for other options.

This should get you back to before you made the errant formula. Provided you have a recent Time Machine backup.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .