2

My old MacBook has come out of retirement after about two years turned off. It connected to my WiFi but the browsers complain it's insecure and might be connected to servers pretending to be the ones I'm entering. And my ISP's security features are warning me I'm not using their DNS (which explains the browser warnings too I guess).

I've tried forgetting the network and logging back in, and deleting any DNS settings I can see in system settings, and re-setting DHCP->manual and back, and nothing works.

Do I need to wipe all WiFi settings or is there something else? On ethernet it works fine (it's one of those antique MacBooks before Apple improved them by removing such things).

2

IIRC, there is a pretty simple way to do this! The first set of instructions in this link explains it pretty well, but in case the link breaks, here is the text from the site. The idea is to delete the network configuration related plist files.

  1. Turn off Wi-Fi from the menu bar.
  2. Navigate to /Library/Preferences/SystemConfiguration/ in Finder by pressing ⌘ + Shift + G.
  3. Select the following files:
    • com.apple.airport.preferences.plist
    • com.apple.network.identification.plist
    • com.apple.wifi.message-tracer.plist
    • NetworkInterfaces.plist
    • preferences.plist
  4. Copy these files in a safe location so that if anything gets messed up, you can easily restore them.
  5. Delete the files (from the original location).
  6. Reboot your Mac and enable Wi-Fi again.

Let me know how this goes!

Via the command line:

cd /Library/Preferences/SystemConfiguration/
sudo zip backup.zip \
         com.apple.airport.preferences.plist       \
         com.apple.network.identification.plist    \
         com.apple.wifi.message-tracer.plist       \
         NetworkInterfaces.plist preferences.plist
sudo rm  com.apple.airport.preferences.plist       \
         com.apple.network.identification.plist    \
         com.apple.wifi.message-tracer.plist       \
         NetworkInterfaces.plist preferences.plist

Note: In macOS Mojave 10.14.4, the file com.apple.network.identification.plist didn't exist on atleast 1 machine where this was tested. The file not found errors can be ignored.

  • Thank you for this. I added CLI instructions. – Bruno Bronosky Jun 13 at 18:18
  • I had an issue where I used to connect to the wifi on my ISP's provided modem, but later put a router in front of it with the same SSID and password. (At my boss's direction.) My Mac continued to use the modem's DHCP even though it was connected to the router! Removing these files is the only thing that worked. – Bruno Bronosky Jun 13 at 19:01

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .