2

How do I disable autocomplete on macOS Sierra for MacBook, please, without disabling it on iOS 10 for iPhone?

Seems to occur only in native/Apple apps. Appears below my typing as blue text in a white rectangle with a close button on its right.

It flashes for a split second before inserting its suggestion into my typing, without feedback from me.

The suggestions are listed in Syst Prefs / Keyboard / Text / Replace…With. These I created on my phone's device Settings / General / Keyboard / Text Replacement, but I never asked for them to be applied to macOS. How'd they get there?

If I delete them from the Mac, they also delete from the phone. How might I remove/disable them from one but not the other? Thank you.

1

Explanation

The text replacements in System Preferences > Keyboard > Text (macOS) and Settings > General > Keyboard > Text Replacement (iOS) are tightly integrated into iCloud.

In fact, both sync using iCloud and are stored in your iCloud Drive (com.apple.TextInput). This is an invisible folder.


Disable text replacements on macOS

In order to disable them on your Mac, you have two options:

  • iOS: In Settings > iCloud > iCloud disable 'iCloud Drive'.
  • macOS: In System Preferences > iCloud > iCloud Drive (Options) disable 'System Preferences'.

Now you need to delete your text replacements from your Mac. You may create a backup of them by selecting all (CMD+A) and dragging them on your Desktop.

Was this answer helpful?

  • If I untick "System Preferences" from "iCloud Drive (Options)", I'd expect that would halt the syncing of all syst prefs across my different Macs. – jtheletter Sep 17 '17 at 3:21

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .