1

From time to time the (Apple USB) keyboard of my imac (21.5-inch, Mid 2010, mac os 10.12.5) gets stuck on caps lock (namely all letters are printed capital, and I can't turn capital off), and I have to unplug the USB cable to fix this; when I plug it back, the light is on, and I can turn caps lock off. This happens more frequently after installing mac os updates, then it gradually becomes less frequent.

Are there an explanation and a solution for this issue?

2
  • 1
    More than likely, you need a new keyboard. Try it with a different keyboard (even a PC keyboard will work). If the problem goes away, you have your answer.
    – Allan
    May 19, 2017 at 18:02
  • This was happening to me too. So weird. Unplugging the keyboard worked
    – fersarr
    Mar 9, 2018 at 9:11

1 Answer 1

-2

Just unplug the USB from the back of your computer. Plug the USB back into the computer. Solved.

2
  • It looks like the author of the question was already doing that ...
    – Glorfindel
    Feb 7, 2018 at 12:31
  • You don't seem to have actually read the whole question. Best delete this answer. Feb 7, 2018 at 12:35

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .