4

My issue is that preview is no longer rendering text properly, everything is very blurry with some pages being unreadable. This happens across multiple PDFs, so it's not tied to just one. Strangely, if I set it to single page mode and then proceed swipe up/down slowly, showing moving to the next page, both the current and the next page render perfectly fine.

This is that what the text should look like: This is what it should look like

This is what the text actually looks like in a best case scenario. enter image description here

By the way, I have a 2013 15" rMBP.

  • What screen resolution? – Jash Jacob May 19 '17 at 17:19
  • I have it scaled to 1920x1080. – user9985 May 19 '17 at 17:21
  • That could be your problem. Try using default for the display and see if that helps – NoahL May 19 '17 at 17:35
  • @NoahL, closing preview, switching to default, opening preview, closing preview, switching back to scaled seems to have fixed it for all of the resolutions. Really strange though. – user9985 May 19 '17 at 17:49
1

As per the discussion above, changing the scaling to the default setting and back seems to fix the issue.

  • This does not provide an answer to the question. To critique or request clarification from an author, leave a comment below their post. - From Review – IconDaemon May 19 '17 at 21:08
  • @Icon Why does this not answer the question? It provides the solution, changing the scaling. – grg May 19 '17 at 21:53
  • This is actually the solution. It has happened to me quite few times. Screen scaling is always the issue for these. So many bugs. – Jash Jacob May 20 '17 at 1:30
  • @grgarside - In NoahL's comment, which is the solution to the question, the OP already indicates that it works. There is no need to further belabor the issue by the OP creating another 'answer'. NoahL should be encouraged to write up his solution as a formal answer and thus receive credit where credit is due. – IconDaemon May 20 '17 at 12:57
  • @IconDaemon, I agree that NoahL should get credit for it so I won't be accepting my answer as the answer. I put it up there so that people with the same problem don't miss it by not reading the comments. – user9985 May 20 '17 at 16:18
1

Screen scaling a Retina MBP brings up a lot of issues when running on Integrated GPU (Intel HD or Intel iris) as it hogs the system memory. If you have a dedicated GPU on the MacBook Pro, turn off the automatic GPU switching(System Preferences -> Energy Saver) which will reduce these issues when scaling the screen from it's default resolution.

If you only have Integrated GPU, Try running on default scaling when running memory intensive tasks.

enter image description here

  • Interesting, I will keep it in mind. I will take your word on it that it helps, since I personally didn't try this as changing the scaling helped. – user9985 May 20 '17 at 16:19

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .