1

Few keys like i, k and l are not working for my login. These keys work at login screen and for other users. Had a conversation with Apple support online chat and we went thru the following but issue is not resolved yet.

We did the following

  • NVRAM Reset
  • System Management Controller (SMC) reset
  • macOS Recovery
  • Updated latest OS :macOS Sierra 10.12.5
  • Reinstall macOS using macOS Utilities

During the process, app representative asked me to create new login and try and it worked.

Wondering if you have seen this issue on your Macbooks. I have so much data in my login and I haven't thought about it moving data to new login.

Thanks

  • On the chat you were on, has your case been pushed to Apple Engineers? – NoahL May 19 '17 at 17:34
  • I did not get any response from Apple rep at the end. We were working on this for more than 2 hours and when we started last step (Reinstall macOS) and it took more than 20 minutes and it was past mid night and I closed the chat as I did not get any response. – RedFox May 19 '17 at 17:55
  • Try contacting again (using the case number you were given) and ask if they will push it up to the engineering team. – NoahL May 19 '17 at 18:45
  • I've a Genius Bar reservation at local store tomorrow. Will update the thread after my visit. – RedFox May 19 '17 at 22:39
  • I know you have a Genius Bar appointment tomorrow, but one thing you haven't tried, is booting into Safe Mode. This would be a good troubleshooting step to do before your appointment. To do this, Boot your MBP up in Safe Mode and try using the media controls keys. To do this, hold the shift key down as you boot up. This will take a little longer to boot as your Mac cleans caches, runs some diagnostics, etc. Once you've tested the keyboard, exit Safe Mode by restarting your Mac and then test the keys again. Even if this doesn't fix things, it's valuable info for us (or the Genius Bar!). – Monomeeth May 19 '17 at 23:37
0

Go to system preferences/accessibility/mouse & trackpad and uncheck the box for Enable Mouse Keys.

https://support.apple.com/kb/PH25642

  • `yes. I have. Apple person helped me with this. – RedFox May 19 '17 at 22:33
  • @RedFox what other keys besides ikl do not work? – Tom Gewecke May 19 '17 at 22:40
1

simply, switch to guest account,go to system preferences..see image attached. Then switch back to user account and login using virtual keyboard. I do it everytime.enter image description here

enter image description here

0

I had to bring in a new 2016 Macbook Pro (no touchbar) after a few weeks due to keys not working, sticking, etc. This is a known issue. Apple Store gave me a new unit after they had to send mine out and it was over 5 days and still no idea when it was coming back.

https://www.macrumors.com/2017/02/21/2016-macbook-pro-keyboard-issues/

  • But surely such a problem would not go away in another account, like he says his does. – Tom Gewecke May 19 '17 at 22:07
  • True...that part makes no sense (to me). – Sizzle May 19 '17 at 22:27
  • yes. It doesn't make any sense. But it's happening. – RedFox May 19 '17 at 22:34
0

Another culprit is using Real VNC viewer. While running (even when you're not connected) it seems to take over SOME of the function keys. For me it was everything but F3 and F4. Killing Real VNC fixed the problem immediately.

0

My n key was not working - took it to the Genius Bar and they are giving me a new computer. 2017 MacBook Pro with Touch Bar. N key would skip sometimes and sometimes repeat. Apple said they wanted to keep mine “to evaluate in order to improve products and services.” Called it the “capture program.” Supposed to get the new unit today, and it will have a 1 year warranty but I am purchasing the Apple Care Plan for dang sure.

  • 1
    Was the 'n' key sometimes working yet other times (seemingly random) stop working? May have similar/same issue. – JBis Apr 26 '18 at 12:11
  • 1
    Yes. It was totally random and entirely frustrating. – Shannon Apr 26 '18 at 14:12
  • Compressed air did nothing to fix it. – Shannon Apr 26 '18 at 14:16
  • Thank you! Lastly, Can you tell me the configuration of that computer? Want to see if the issue is localized to a single configuration. – JBis Apr 26 '18 at 14:59
  • It was malfunctioning more often than it was working properly, though. I had a malfunctioning r key a few months ago, but compressed air took care of that issue. – Shannon Apr 26 '18 at 16:32
-1

Genius bar person took only a minute to figure this out. It turned out be Mouse Keys. I am surprised that the person I chat for couple of hours didn't know this.

Somehow, Option key was pressed five times and it turned on the Mouse keys. http://www.macworld.com/article/1157890/computers/mousefreemac.html

Thank you all for your help.

  • It only took me a minute as well, and I posted the answer here two days ago. – Tom Gewecke May 22 '17 at 19:36
  • Yes. I overlooked your answer. :-( At that time I didn't know about mouse key – RedFox May 22 '17 at 20:10

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .