4

I have set + M to execute the command "Paste and Match Style", system-wide. I assigned this custom shortcut at the following location:

System PreferencesKeyboardApp ShortcutsAll Applications

However, instead of the desired effect of pasting and matching style, pressing + M on my keyboard usually types the character µ instead. Only every so often does my shortcut randomly function correctly.

How can I disable the assignment of this special character to my shortcut, so that the shortcut is dedicated to my user-defined command? I never have the need to type this Mu character, so I have no problem with ridding it from my keyboard entirely.

I understand that one can use a re-mapping program (such as Karabiner.app) as a workaround to accomplish this. But, does Apple offer a built-in way to remove special character shortcuts?

1

As a workaround, since I know you use FastScripts, here's a suggestion.

Undo the changes you made in System Preferences > Keyboard > Application Shortcuts > All Applications, by first changing ⌥M back to ⌥⇧⌘V, then delete the Paste and Match Style command you added. Note that you could probably just delete it without first reseting it to its default key sequence, however I do it this way to insure it gets reset properly.

With things back to normal, create an AppleScript .scpt using the code below, saving it as Paste and Match Style.scpt in the Users Script Folder (~/Library/Scripts).

tell application "System Events" to key code 9 using {option down, shift down, command down}

Note that you can also use keystroke "v" in place of key code 9, I just prefer to use key code over keystroke most of the time.

In FastScripts > Preferences... > Script Shortcuts, assign ⌥M to: Paste and Match Style

Now you will not get the µ character when pressing ⌥M when FastScripts is running.

1

Apple always uses Option/alt for special characters. Just use Control or Command for the functions you want instead.

  • The key is also already bound to almost the entire alphabet and other characters like +, -, [, ], 0 thru 9, etc. throughout the combined installed apps, so is not ideal for two key combo to circumvent a default like ⌥M, as ⌘M is set to Minimize. My suggested workaround is IMO a good option in this case since I know that rubik's sphere uses FastScript. – user3439894 May 18 '17 at 16:38
  • 1
    Ctrl is bound to much less though. The answer is IMHO not correct anyway because it does not actually answer the question but simply propose a workaround. It should have been a comment at most. – Frizlab May 18 '17 at 20:38
  • I think that using the Control key is a fine idea. My gripe is that Apple surely is aware that the majority of Mac users never have the need to type any special characters. Yet, they continue to dedicate a number of shortcuts to these esoteric symbols. I guess that Apple's rebuttal would be... "How many people need more keyboard shortcuts than the dozens of shortcuts that the ctrl key provides?" – rubik's sphere May 20 '17 at 1:32
  • @rubik'ssphere Apple gets 2/3 of its sales from outside the US in fact spends a lot of effort to localize MacOS and iOS and provide easy modes of input for languages other than English. – Tom Gewecke May 20 '17 at 12:45

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .