0

This is quite weird. Amazon had a recent update and when I tried updating it a message popped up saying that it is not longer available. However, the badge icon is always visible and it's stuck there waiting to be updated. Clicking on the app in the update page will prompt a message that asks to change store location because this item is not available in my country. But when I switch, it says I don't have an account/payment option for that country, and changes back to my home country.

I tried the following :

  • logging out and in from iTunes
  • deleting the app and reinstalling
  • restarting phone
  • updating app to another version released today
  • enabling/disabling automatic downloads
  • clearing cache in App Store

None of these mthods solved the problem. I still have a badge icon in the App Store. Any ideas how to fix this?

iOS 10.3.1 - iPhone 7 plus

  • What countries app store are you using? – Tyson May 18 '17 at 14:20
  • My main is the UAE store, but clicking on the amazon app through the update links switches to the Italian one. – Render May 19 '17 at 14:29
0

Updating to the new iOS fixed my problem.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .